WordPress.org

Make WordPress Core

Changeset 50459 for branches/5.6


Ignore:
Timestamp:
03/01/2021 08:27:03 AM (4 months ago)
Author:
SergeyBiryukov
Message:

External Libraries: Install jQuery via NPM.

Previously, jQuery 1.12.4 was added to the WordPress SVN repo in order to backport an upstream security patch from jQuery 3.4.0.

Now that WordPress includes an unmodified version of jQuery 3.5.1 and no longer needs to maintain a fork, it can be removed from the SVN repo and installed via NPM again as part of the build.

Follow-up to [45342], [49101].

Props peterwilsoncc, SergeyBiryukov.
Merges [50445] to the 5.6 branch.
Fixes #52647.

Location:
branches/5.6
Files:
2 deleted
3 edited

Legend:

Unmodified
Added
Removed
  • branches/5.6

  • branches/5.6/Gruntfile.js

    r50184 r50459  
    186186                        [ WORKING_DIR + 'wp-includes/js/hoverintent-js.min.js' ]: [ './node_modules/hoverintent/dist/hoverintent.min.js' ],
    187187                        [ WORKING_DIR + 'wp-includes/js/imagesloaded.min.js' ]: [ './node_modules/imagesloaded/imagesloaded.pkgd.min.js' ],
     188                        [ WORKING_DIR + 'wp-includes/js/jquery/jquery.js' ]: [ './node_modules/jquery/dist/jquery.js' ],
     189                        [ WORKING_DIR + 'wp-includes/js/jquery/jquery.min.js' ]: [ './node_modules/jquery/dist/jquery.min.js' ],
    188190                        [ WORKING_DIR + 'wp-includes/js/jquery/jquery.form.js' ]: [ './node_modules/jquery-form/src/jquery.form.js' ],
    189191                        [ WORKING_DIR + 'wp-includes/js/masonry.min.js' ]: [ './node_modules/masonry-layout/dist/masonry.pkgd.min.js' ],
  • branches/5.6/package.json

    r50405 r50459  
    135135        "hoverintent": "2.2.1",
    136136        "imagesloaded": "4.1.4",
     137        "jquery": "3.5.1",
    137138        "jquery-color": "https://github.com/jquery/jquery-color/archive/2.1.2.tar.gz",
    138139        "jquery-form": "4.2.1",
Note: See TracChangeset for help on using the changeset viewer.