Make WordPress Core

Changeset 50929 for trunk/package.json


Ignore:
Timestamp:
05/19/2021 03:07:55 PM (3 years ago)
Author:
gziolo
Message:

Editor: Update WordPress packages published for Gutenberg 10.6

It contains several changes in addition to regular update to WordPress packages:

  • All newly exposed blocks are now registered on the server.
  • Dutone block support was added.
  • Border block support was updated.
  • New shared function construct_wp_query_args was added for the family of Query blocks - it might need some further work.

Props youknowriad.
See #52991.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/package.json

    r50843 r50929  
    2525    ],
    2626    "devDependencies": {
    27         "@wordpress/custom-templated-path-webpack-plugin": "2.0.3",
    28         "@wordpress/dependency-extraction-webpack-plugin": "3.1.2",
    29         "@wordpress/e2e-test-utils": "5.1.3",
    30         "@wordpress/library-export-default-webpack-plugin": "2.0.3",
    31         "@wordpress/scripts": "15.0.1",
     27        "@wordpress/custom-templated-path-webpack-plugin": "2.0.4",
     28        "@wordpress/dependency-extraction-webpack-plugin": "3.1.3",
     29        "@wordpress/e2e-test-utils": "5.1.4",
     30        "@wordpress/library-export-default-webpack-plugin": "2.0.4",
     31        "@wordpress/scripts": "16.0.0",
    3232        "autoprefixer": "^9.8.6",
    3333        "chalk": "4.1.0",
     
    7878    "dependencies": {
    7979        "@babel/polyfill": "7.10.1",
    80         "@wordpress/a11y": "2.15.3",
    81         "@wordpress/annotations": "1.25.3",
    82         "@wordpress/api-fetch": "4.0.0",
    83         "@wordpress/autop": "2.12.2",
    84         "@wordpress/blob": "2.13.2",
    85         "@wordpress/block-directory": "1.19.3",
    86         "@wordpress/block-editor": "5.3.3",
    87         "@wordpress/block-library": "2.29.3",
    88         "@wordpress/block-serialization-default-parser": "3.10.2",
    89         "@wordpress/blocks": "8.0.3",
    90         "@wordpress/components": "13.0.3",
    91         "@wordpress/compose": "3.25.3",
    92         "@wordpress/core-data": "2.26.3",
    93         "@wordpress/data": "4.27.3",
    94         "@wordpress/data-controls": "1.21.3",
    95         "@wordpress/date": "3.15.1",
    96         "@wordpress/deprecated": "2.12.3",
    97         "@wordpress/dom": "2.18.0",
    98         "@wordpress/dom-ready": "2.13.2",
    99         "@wordpress/edit-post": "3.27.3",
    100         "@wordpress/editor": "9.26.3",
    101         "@wordpress/element": "2.20.3",
    102         "@wordpress/escape-html": "1.12.2",
    103         "@wordpress/format-library": "1.27.3",
    104         "@wordpress/hooks": "2.12.3",
    105         "@wordpress/html-entities": "2.11.2",
    106         "@wordpress/i18n": "3.20.0",
    107         "@wordpress/icons": "2.10.3",
    108         "@wordpress/interface": "2.0.2",
    109         "@wordpress/is-shallow-equal": "3.1.3",
    110         "@wordpress/keyboard-shortcuts": "1.14.3",
    111         "@wordpress/keycodes": "2.19.3",
    112         "@wordpress/list-reusable-blocks": "1.26.3",
    113         "@wordpress/media-utils": "1.20.3",
    114         "@wordpress/notices": "2.13.3",
    115         "@wordpress/nux": "3.25.3",
    116         "@wordpress/plugins": "2.25.3",
    117         "@wordpress/primitives": "1.12.3",
    118         "@wordpress/priority-queue": "1.11.2",
    119         "@wordpress/redux-routine": "3.14.2",
    120         "@wordpress/reusable-blocks": "1.2.3",
    121         "@wordpress/rich-text": "3.25.3",
    122         "@wordpress/server-side-render": "1.21.3",
    123         "@wordpress/shortcode": "2.13.2",
    124         "@wordpress/token-list": "1.15.3",
    125         "@wordpress/url": "2.22.2",
    126         "@wordpress/viewport": "2.26.3",
    127         "@wordpress/warning": "1.4.2",
    128         "@wordpress/wordcount": "2.15.2",
     80        "@wordpress/a11y": "3.0.0",
     81        "@wordpress/annotations": "2.0.0",
     82        "@wordpress/api-fetch": "5.0.0",
     83        "@wordpress/autop": "3.0.0",
     84        "@wordpress/blob": "3.0.0",
     85        "@wordpress/block-directory": "2.0.0",
     86        "@wordpress/block-editor": "6.0.0",
     87        "@wordpress/block-library": "3.0.0",
     88        "@wordpress/block-serialization-default-parser": "4.0.0",
     89        "@wordpress/blocks": "9.0.0",
     90        "@wordpress/components": "14.0.0",
     91        "@wordpress/compose": "4.0.0",
     92        "@wordpress/core-data": "3.0.0",
     93        "@wordpress/data": "5.0.0",
     94        "@wordpress/data-controls": "2.0.0",
     95        "@wordpress/date": "4.0.0",
     96        "@wordpress/deprecated": "3.0.0",
     97        "@wordpress/dom": "3.0.0",
     98        "@wordpress/dom-ready": "3.0.0",
     99        "@wordpress/edit-post": "4.0.0",
     100        "@wordpress/editor": "10.0.0",
     101        "@wordpress/element": "3.0.0",
     102        "@wordpress/escape-html": "2.0.0",
     103        "@wordpress/format-library": "2.0.0",
     104        "@wordpress/hooks": "3.0.0",
     105        "@wordpress/html-entities": "3.0.0",
     106        "@wordpress/i18n": "4.0.0",
     107        "@wordpress/icons": "3.0.0",
     108        "@wordpress/interface": "3.0.0",
     109        "@wordpress/is-shallow-equal": "4.0.0",
     110        "@wordpress/keyboard-shortcuts": "2.0.0",
     111        "@wordpress/keycodes": "3.0.0",
     112        "@wordpress/list-reusable-blocks": "2.0.0",
     113        "@wordpress/media-utils": "2.0.0",
     114        "@wordpress/notices": "3.0.0",
     115        "@wordpress/nux": "4.0.0",
     116        "@wordpress/plugins": "3.0.0",
     117        "@wordpress/primitives": "2.0.0",
     118        "@wordpress/priority-queue": "2.0.0",
     119        "@wordpress/redux-routine": "4.0.0",
     120        "@wordpress/reusable-blocks": "2.0.0",
     121        "@wordpress/rich-text": "4.0.0",
     122        "@wordpress/server-side-render": "2.0.0",
     123        "@wordpress/shortcode": "3.0.0",
     124        "@wordpress/token-list": "2.0.0",
     125        "@wordpress/url": "3.0.0",
     126        "@wordpress/viewport": "3.0.0",
     127        "@wordpress/warning": "2.0.0",
     128        "@wordpress/wordcount": "3.0.0",
    129129        "backbone": "1.4.0",
    130130        "clipboard": "2.0.8",
Note: See TracChangeset for help on using the changeset viewer.