Make WordPress Core


Ignore:
Timestamp:
05/25/2021 01:41:30 PM (3 years ago)
Author:
youknowriad
Message:

Block Editor: Load theme resolver class in script loader.

script-loader.php is sometimes called directly and in these situations, the Theme_JSON_Resolver class was not defined.

Props nosolosw, noisysocks.
Fixes #53175.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/src/wp-settings.php

    r50995 r51001  
    300300require ABSPATH . WPINC . '/blocks/index.php';
    301301require ABSPATH . WPINC . '/class-wp-theme-json.php';
    302 require ABSPATH . WPINC . '/class-wp-theme-json-resolver.php';
     302require_once ABSPATH . WPINC . '/class-wp-theme-json-resolver.php';
    303303require ABSPATH . WPINC . '/block-editor.php';
    304304require ABSPATH . WPINC . '/block-patterns.php';
Note: See TracChangeset for help on using the changeset viewer.