Make WordPress Core

Changeset 51146 for trunk/package.json


Ignore:
Timestamp:
06/14/2021 11:16:27 PM (3 years ago)
Author:
desrosj
Message:

Build/Test Tools: Replace the deprecated @babel/polyfill.

This replaces the dependency of the deprecated @babel/polyfill package with the core-js package through @wordpress/babel-preset-default.

Previously, the file consisted of a generalized group of polyfills, and not all of them were required. This change allows the contents of this file to be built according to the exact needs as dictated by the @wordpress/babel-preset-default package, which takes into account the current browser support.

Props gziolo, youknowriad.
Fixes #52941.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/package.json

    r51113 r51146  
    2525    ],
    2626    "devDependencies": {
     27        "@wordpress/babel-preset-default": "6.2.0",
    2728        "@wordpress/custom-templated-path-webpack-plugin": "2.0.5",
    2829        "@wordpress/dependency-extraction-webpack-plugin": "3.1.4",
     
    7778    },
    7879    "dependencies": {
    79         "@babel/polyfill": "7.10.1",
    8080        "@wordpress/a11y": "3.1.1",
    8181        "@wordpress/annotations": "2.1.1",
Note: See TracChangeset for help on using the changeset viewer.