Make WordPress Core

Changeset 51421 for trunk/package.json


Ignore:
Timestamp:
07/13/2021 04:39:05 PM (3 years ago)
Author:
youknowriad
Message:

Block Editor: Include the fixes targetted for WordPress 5.8 RC3.

This includes the following fixes:

  • Safari: see if compositing layer size is more reasonable when position fixed divs are not inserted into content.
  • Site Logo Block: update Site Logo block UI and option syncing.
  • Fix moving inner blocks in the Widgets Customizer.
  • Allow themes to provide empty values for color.duotone and spacing.units
  • Update getTermsInfo() to workaround parsing issue for translatable strings.
  • Specify what settings can be part of settings.layout.
  • Update conditions to hide duotone panel.
  • Prevent entering invalid values in the Query Loop block config.
  • Prevent color panel from showing as empty.
  • Avoid calling gutenberg_ functions within code shipped through WordPress Core.

Props desrosj.
See #53397.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/package.json

    r51362 r51421  
    8383        "@wordpress/autop": "3.1.1",
    8484        "@wordpress/blob": "3.1.1",
    85         "@wordpress/block-directory": "2.1.16",
    86         "@wordpress/block-editor": "6.1.9",
    87         "@wordpress/block-library": "3.2.14",
     85        "@wordpress/block-directory": "2.1.17",
     86        "@wordpress/block-editor": "6.1.10",
     87        "@wordpress/block-library": "3.2.15",
    8888        "@wordpress/block-serialization-default-parser": "4.1.1",
    8989        "@wordpress/blocks": "9.1.5",
    90         "@wordpress/components": "14.1.6",
     90        "@wordpress/components": "14.1.7",
    9191        "@wordpress/compose": "4.1.3",
    9292        "@wordpress/core-data": "3.1.9",
    93         "@wordpress/customize-widgets": "1.0.15",
     93        "@wordpress/customize-widgets": "1.0.16",
    9494        "@wordpress/data": "5.1.3",
    9595        "@wordpress/data-controls": "2.1.3",
     
    9898        "@wordpress/dom": "3.1.2",
    9999        "@wordpress/dom-ready": "3.1.1",
    100         "@wordpress/edit-post": "4.1.16",
    101         "@wordpress/edit-widgets": "2.1.16",
    102         "@wordpress/editor": "10.1.12",
     100        "@wordpress/edit-post": "4.1.17",
     101        "@wordpress/edit-widgets": "2.1.17",
     102        "@wordpress/editor": "10.1.13",
    103103        "@wordpress/element": "3.1.1",
    104104        "@wordpress/escape-html": "2.1.1",
    105         "@wordpress/format-library": "2.1.9",
     105        "@wordpress/format-library": "2.1.10",
    106106        "@wordpress/hooks": "3.1.1",
    107107        "@wordpress/html-entities": "3.1.1",
    108108        "@wordpress/i18n": "4.1.1",
    109109        "@wordpress/icons": "4.0.2",
    110         "@wordpress/interface": "3.1.7",
     110        "@wordpress/interface": "3.1.8",
    111111        "@wordpress/is-shallow-equal": "4.1.1",
    112112        "@wordpress/keyboard-shortcuts": "2.1.3",
    113113        "@wordpress/keycodes": "3.1.1",
    114         "@wordpress/list-reusable-blocks": "2.1.6",
     114        "@wordpress/list-reusable-blocks": "2.1.7",
    115115        "@wordpress/media-utils": "2.1.1",
    116116        "@wordpress/notices": "3.1.3",
    117         "@wordpress/nux": "4.1.6",
     117        "@wordpress/nux": "4.1.7",
    118118        "@wordpress/plugins": "3.1.3",
    119119        "@wordpress/primitives": "2.1.1",
    120120        "@wordpress/priority-queue": "2.1.1",
    121121        "@wordpress/redux-routine": "4.1.1",
    122         "@wordpress/reusable-blocks": "2.1.12",
     122        "@wordpress/reusable-blocks": "2.1.13",
    123123        "@wordpress/rich-text": "4.1.3",
    124         "@wordpress/server-side-render": "2.1.7",
     124        "@wordpress/server-side-render": "2.1.8",
    125125        "@wordpress/shortcode": "3.1.1",
    126126        "@wordpress/token-list": "2.1.1",
     
    128128        "@wordpress/viewport": "3.1.3",
    129129        "@wordpress/warning": "2.1.1",
    130         "@wordpress/widgets": "1.1.14",
     130        "@wordpress/widgets": "1.1.15",
    131131        "@wordpress/wordcount": "3.1.1",
    132132        "backbone": "1.4.0",
Note: See TracChangeset for help on using the changeset viewer.