Make WordPress Core

Changeset 51933


Ignore:
Timestamp:
10/25/2021 07:16:32 PM (2 years ago)
Author:
desrosj
Message:

Build/Test Tools: Change the patch version used for testing the 5.6 branch of PHP.

This unpins the version of PHP 5.6.20 used when testing the 5.6 branch of PHP.

Using 5.6.20 was an intentional decision in [49162], as that patch version is the oldest version of PHP 5.6 still supported by WordPress. However, as of September 30, 2021, the 5.6.20 image contains a version of OpenSSL with an expired certificate, sometimes resulting in an expired trust chain.

Props Clorith, hellofromTonya, SergeyBiryukov, desrosj.
Merges [51890] to the 5.6 branch.
See #54223.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • branches/5.6/.github/workflows/phpunit-tests.yml

    r51840 r51933  
    7474      fail-fast: false
    7575      matrix:
    76         php: [ '5.6.20', '7.0', '7.1', '7.2', '7.3', '7.4', '8.0' ]
     76        php: [ '5.6', '7.0', '7.1', '7.2', '7.3', '7.4', '8.0' ]
    7777        os: [ ubuntu-latest ]
    7878        memcached: [ false ]
Note: See TracChangeset for help on using the changeset viewer.