Make WordPress Core

Changeset 54431


Ignore:
Timestamp:
10/10/2022 04:45:54 AM (22 months ago)
Author:
peterwilsoncc
Message:

Security: Introduce strings to indicate support status.

Add strings for use in future maintenance/security releases to indicate the security support status of the version of WordPress.

Two strings are introduced:

  • indicating the version of WordPress is not receiving security updates, and,
  • indicating the version of WordPress will shortly stop receiving security updates.

This change does not make use of the strings, the purpose is to make them available to translators prior to dropping support of selected versions of WordPress.

Props costdev, chesio, robinwpdeveloper, desrosj, rudlinkon, mukesh27, sumitbagthariya16.
Merges [54322] to the 5.9 branch.
See #56532.

Location:
branches/5.9
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • branches/5.9

  • branches/5.9/src/wp-admin/about.php

    r53988 r54431  
    450450/* translators: %s: Documentation URL. */
    451451__( 'For more information, see <a href="%s">the release notes</a>.' );
     452
     453/* translators: 1: WordPress version number, 2: Link to update WordPress */
     454__( 'Important! Your version of WordPress (%1$s) is no longer supported, you will not receive any security updates for your website. To keep your site secure, please <a href="%2$s">update to the latest version of WordPress</a>.' );
     455
     456/* translators: 1: WordPress version number, 2: Link to update WordPress */
     457__( 'Important! Your version of WordPress (%1$s) will stop receiving security updates in the near future. To keep your site secure, please <a href="%2$s">update to the latest version of WordPress</a>.' );
Note: See TracChangeset for help on using the changeset viewer.