Make WordPress Core

Changeset 55622


Ignore:
Timestamp:
04/04/2023 09:00:07 PM (11 months ago)
Author:
audrasjb
Message:

Coding Standards: Use strict comparison in wp-admin/users.php.

Follow-up to [10990], [11162], [11217], [37059], [55592].
Props moinrrahmed.
Fixes #58056.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/src/wp-admin/users.php

    r55412 r55622  
    146146
    147147            // The new role of the current user must also have the promote_users cap or be a multisite super admin.
    148             if ( $id == $current_user->ID && ! $wp_roles->role_objects[ $role ]->has_cap( 'promote_users' )
     148            if ( $id === $current_user->ID && ! $wp_roles->role_objects[ $role ]->has_cap( 'promote_users' )
    149149            && ! ( is_multisite() && current_user_can( 'manage_network_users' ) ) ) {
    150150                    $update = 'err_admin_role';
Note: See TracChangeset for help on using the changeset viewer.