Make WordPress Core


Ignore:
Timestamp:
05/19/2023 12:44:54 PM (9 months ago)
Author:
spacedmonkey
Message:

Networks and Sites: Load WP_Metadata_Lazyloader class file if class in meta.php.

In [55818] did a check to see if WP_Metadata_Lazyloader class existed and the loaded in the class file if it did not. However, require in wp-settings.php was not removed and resulted in the class being loaded twice. To be safe, only include the class file in meta.php and remove from wp-settings.php file.

Props spacedmonkey, ryelle.
See #58185.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/src/wp-settings.php

    r55443 r55826  
    189189require ABSPATH . WPINC . '/class-wp-session-tokens.php';
    190190require ABSPATH . WPINC . '/class-wp-user-meta-session-tokens.php';
    191 require ABSPATH . WPINC . '/class-wp-metadata-lazyloader.php';
    192191require ABSPATH . WPINC . '/general-template.php';
    193192require ABSPATH . WPINC . '/link-template.php';
Note: See TracChangeset for help on using the changeset viewer.