Make WordPress Core


Ignore:
Timestamp:
06/23/2023 08:04:30 PM (8 months ago)
Author:
SergeyBiryukov
Message:

Bootstrap/Load: Require wp-includes/compat.php earlier in wp-settings.php.

This allows for using polyfill functions in more files, including the advanced-cache.php drop-in.

Follow-up to [6108], [46183], [55988], [55990], [56006].

See #58206.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/src/wp-settings.php

    r55826 r56007  
    3838
    3939// Include files required for initialization.
     40require ABSPATH . WPINC . '/compat.php';
    4041require ABSPATH . WPINC . '/class-wp-paused-extensions-storage.php';
    4142require ABSPATH . WPINC . '/class-wp-fatal-error-handler.php';
     
    105106
    106107// Load early WordPress files.
    107 require ABSPATH . WPINC . '/compat.php';
    108108require ABSPATH . WPINC . '/class-wp-list-util.php';
    109109require ABSPATH . WPINC . '/formatting.php';
Note: See TracChangeset for help on using the changeset viewer.