Make WordPress Core

Changeset 56646


Ignore:
Timestamp:
09/21/2023 12:26:53 PM (8 months ago)
Author:
desrosj
Message:

External Libraries: Update the polyfill-library package.

This updates the wp-polyfill-node-contains and 'wp-polyfill-dom-rect scripts to the latest version, 4.8.0.

These scripts are no longer used by WordPress Core, but are kept up to date as a courtesy.

Props rajinsharwar, hrshahin, oglekler.
Fixes #59077.

Location:
trunk
Files:
3 edited

Legend:

Unmodified
Added
Removed
  • trunk/package-lock.json

    r56626 r56646  
    9292                "objectFitPolyfill": "2.3.5",
    9393                "path-to-regexp": "6.2.1",
    94                 "polyfill-library": "4.7.0",
     94                "polyfill-library": "4.8.0",
    9595                "react": "18.2.0",
    9696                "react-dom": "18.2.0",
     
    2511225112        },
    2511325113        "node_modules/polyfill-library": {
    25114             "version": "4.7.0",
    25115             "resolved": "https://registry.npmjs.org/polyfill-library/-/polyfill-library-4.7.0.tgz",
    25116             "integrity": "sha512-9gftEm1xj8nDQsmBtY+9A7TBuG/HSzUxuPge9/41L77HP/EGV6V4JB+Y5oO3Fz0MfLtswrUtcIIz6qzT1uM+MA==",
     25114            "version": "4.8.0",
     25115            "resolved": "https://registry.npmjs.org/polyfill-library/-/polyfill-library-4.8.0.tgz",
     25116            "integrity": "sha512-7+EjQmy3C7WJRaqCcVFXDE1DLBAIZ9es3DdvBKBxl98kn4kZCjuFKUi13uKDd618DVqZDkvqorP+pBFs7v5feQ==",
    2511725117            "dependencies": {
    2511825118                "@financial-times/polyfill-useragent-normaliser": "^2.0.1",
  • trunk/package.json

    r56626 r56646  
    159159        "objectFitPolyfill": "2.3.5",
    160160        "path-to-regexp": "6.2.1",
    161         "polyfill-library": "4.7.0",
     161        "polyfill-library": "4.8.0",
    162162        "react": "18.2.0",
    163163        "react-dom": "18.2.0",
  • trunk/src/wp-includes/script-loader.php

    r56627 r56646  
    114114        'wp-polyfill-fetch'           => '3.6.17',
    115115        'wp-polyfill-formdata'        => '4.0.10',
    116         'wp-polyfill-node-contains'   => '4.6.0',
     116        'wp-polyfill-node-contains'   => '4.8.0',
    117117        'wp-polyfill-url'             => '3.6.4',
    118         'wp-polyfill-dom-rect'        => '4.6.0',
     118        'wp-polyfill-dom-rect'        => '4.8.0',
    119119        'wp-polyfill-element-closest' => '3.0.2',
    120120        'wp-polyfill-object-fit'      => '2.3.5',
Note: See TracChangeset for help on using the changeset viewer.