Make WordPress Core

Changeset 57173


Ignore:
Timestamp:
12/08/2023 02:11:11 PM (3 months ago)
Author:
desrosj
Message:

Database: Raise the minimum required version of MySQL.

This raises the minimum version of MySQL required to run WordPress from 5.0 to 5.5.5.

MySQL 5.0 and 5.1 have long been unsupported and both reached end of life over 10 years ago. Combined usage for both versions sits at 0.4% of all WordPress sites.

Because 5.5 sits at just under 15% usage, 5.5 cannot be trimmed off at this time.

Of all sites running 5.5.x, 85% are running 5.5.5, and 100% are running 5.5.5 or higher. This makes it the logical landing spot.

Props johnbillion, sergeybiryukov, jorbin.
Fixes #60036.

Location:
trunk/src
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/src/readme.html

    r56982 r57173  
    5353<ul>
    5454    <li><a href="https://secure.php.net/">PHP</a> version <strong>7.0</strong> or greater.</li>
    55     <li><a href="https://www.mysql.com/">MySQL</a> version <strong>5.0</strong> or greater.</li>
     55    <li><a href="https://www.mysql.com/">MySQL</a> version <strong>5.5.5</strong> or greater.</li>
    5656</ul>
    5757
  • trunk/src/wp-includes/version.php

    r57155 r57173  
    4545 * @global string $required_mysql_version
    4646 */
    47 $required_mysql_version = '5.0';
     47$required_mysql_version = '5.5.5';
Note: See TracChangeset for help on using the changeset viewer.