Make WordPress Core

Changeset 57214

Timestamp:
12/20/2023 06:59:17 PM (7 months ago)
Author:
desrosj
Message:

Build/Test Tools: Raise minimum required version of Node.js/npm.

This bumps the minimum required version of Node.js/npm from 16.19.1 and 8.19.3 to 20.10.0 and 10.2.3.

Since 20.10.0 is the latest 20.x version of Node.js, the check-latest option has been enabled for actions/setup-node in GitHub Actions workflows. This performs an additional external call to the Node.js API confirming the latest version is installed on the runner for use. In testing, it seems that 20.10.0 was not consistently deployed to all runner machines in use. This should be removed in the near future when the version of Node.js is reliably above the new minimum requirement.

The Gutenberg repository has also been updated to use the same values for engines.

Merges [57212] to the 6.4 branch.

Props jorbin, joemcgill, swissspidy, benharri, dhrupo, flootr, gziolo, noahtallen.
See #59663.

Location:
branches/6.4
Files:
7 edited

Changeset view not shown, since the total size (4.0 MB) exceeds 4.0 MB

Note: See TracChangeset for help on using the changeset viewer.