Make WordPress Core

Changeset 57529


Ignore:
Timestamp:
02/03/2024 02:22:44 PM (3 weeks ago)
Author:
SergeyBiryukov
Message:

Coding Standards: Use strict comparison in wp-admin/update-core.php.

Follow-up to [11273], [25784], [54654].

Props wpfy, mukesh27, azaozz, viralsampat.
Fixes #58061, #60415.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/src/wp-admin/update-core.php

    r57136 r57529  
    4343    if ( 'en_US' === $update->locale && 'en_US' === get_locale() ) {
    4444        $version_string = $update->current;
    45     } elseif ( 'en_US' === $update->locale && $update->packages->partial && $wp_version == $update->partial_version ) {
     45    } elseif ( 'en_US' === $update->locale && $update->packages->partial && $wp_version === $update->partial_version ) {
    4646        $updates = get_core_updates();
    4747        if ( $updates && 1 === count( $updates ) ) {
     
    180180    echo '</p>';
    181181
    182     if ( 'en_US' !== $update->locale && ( ! isset( $wp_local_package ) || $wp_local_package != $update->locale ) ) {
     182    if ( 'en_US' !== $update->locale && ( ! isset( $wp_local_package ) || $wp_local_package !== $update->locale ) ) {
    183183        echo '<p class="hint">' . __( 'This localized version contains both the translation and various other localization fixes.' ) . '</p>';
    184     } elseif ( 'en_US' === $update->locale && 'en_US' !== get_locale() && ( ! $update->packages->partial && $wp_version == $update->partial_version ) ) {
     184    } elseif ( 'en_US' === $update->locale && 'en_US' !== get_locale() && ( ! $update->packages->partial && $wp_version === $update->partial_version ) ) {
    185185        // Partial builds don't need language-specific warnings.
    186186        echo '<p class="hint">' . sprintf(
Note: See TracChangeset for help on using the changeset viewer.