Make WordPress Core


Ignore:
Timestamp:
05/02/2024 08:29:38 PM (3 months ago)
Author:
jorbin
Message:

Editor: update npm packages for 6.5.3.

Package Update includes fixes for:

– Layout: Skip outputting base layout rules that reference content or wide sizes if no layout sizes exist
– Fix inserter pattern pagination focus loss
– Fix static posts page setting resolved template
– Font Library: Fix modal scrollbar
– Interactivity API: Allow multiple event handlers for the same type with data-wp-on.
– Layout: Always add semantic classes
– List View: Fix stuck dragging mode in UI in Firefox when dealing with deeply nested lists
– Don't output base flow and constrained layout rules on themes without theme.json

  • PHP unit test workflow: Try removing 7.0 and 7.1 to get CI tests passing

Props grantmkin, talldanwp, ntsekouras, mikachan, darerodz, andrewserong, mamaduka, isabel_brison, jorbin, annezazu, anlino, ramonopoly, davecpage, ellatrix, colorful-tones, mamaduka, flixos90, luisherranz, wildworks, jordesign, mmaattiiaass, jorgefilipecosta, kevin940726, afercia, poena, macmanx, luminuu, anlino.
Fixes #61129.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • branches/6.5/package.json

    r57980 r58086  
    3131        "@wordpress/dependency-extraction-webpack-plugin": "5.2.1",
    3232        "@wordpress/e2e-test-utils": "10.22.1",
    33         "@wordpress/e2e-test-utils-playwright": "0.19.2",
     33        "@wordpress/e2e-test-utils-playwright": "0.19.3",
    3434        "@wordpress/prettier-config": "3.8.1",
    35         "@wordpress/scripts": "27.2.5",
     35        "@wordpress/scripts": "27.2.6",
    3636        "autoprefixer": "10.4.17",
    3737        "chalk": "5.3.0",
     
    8484        "@wordpress/autop": "3.51.1",
    8585        "@wordpress/blob": "3.51.1",
    86         "@wordpress/block-directory": "4.28.10",
    87         "@wordpress/block-editor": "12.19.8",
    88         "@wordpress/block-library": "8.28.10",
     86        "@wordpress/block-directory": "4.28.11",
     87        "@wordpress/block-editor": "12.19.9",
     88        "@wordpress/block-library": "8.28.11",
    8989        "@wordpress/block-serialization-default-parser": "4.51.1",
    9090        "@wordpress/blocks": "12.28.6",
     
    9292        "@wordpress/components": "26.0.6",
    9393        "@wordpress/compose": "6.28.1",
    94         "@wordpress/core-commands": "0.20.8",
    95         "@wordpress/core-data": "6.28.8",
    96         "@wordpress/customize-widgets": "4.28.10",
     94        "@wordpress/core-commands": "0.20.9",
     95        "@wordpress/core-data": "6.28.9",
     96        "@wordpress/customize-widgets": "4.28.11",
    9797        "@wordpress/data": "9.21.1",
    9898        "@wordpress/data-controls": "3.20.1",
     
    102102        "@wordpress/dom": "3.51.1",
    103103        "@wordpress/dom-ready": "3.51.1",
    104         "@wordpress/edit-post": "7.28.10",
    105         "@wordpress/edit-site": "5.28.10",
    106         "@wordpress/edit-widgets": "5.28.10",
    107         "@wordpress/editor": "13.28.8",
     104        "@wordpress/edit-post": "7.28.11",
     105        "@wordpress/edit-site": "5.28.11",
     106        "@wordpress/edit-widgets": "5.28.11",
     107        "@wordpress/editor": "13.28.9",
    108108        "@wordpress/element": "5.28.1",
    109109        "@wordpress/escape-html": "2.51.1",
    110         "@wordpress/format-library": "4.28.8",
     110        "@wordpress/format-library": "4.28.9",
    111111        "@wordpress/hooks": "3.51.1",
    112112        "@wordpress/html-entities": "3.51.1",
    113113        "@wordpress/i18n": "4.51.1",
    114114        "@wordpress/icons": "9.42.4",
    115         "@wordpress/interactivity": "5.0.5",
    116         "@wordpress/interactivity-router": "1.1.5",
     115        "@wordpress/interactivity": "5.0.6",
     116        "@wordpress/interactivity-router": "1.1.6",
    117117        "@wordpress/interface": "5.28.6",
    118118        "@wordpress/is-shallow-equal": "4.51.1",
     
    123123        "@wordpress/notices": "4.19.1",
    124124        "@wordpress/nux": "8.13.6",
    125         "@wordpress/patterns": "1.12.8",
     125        "@wordpress/patterns": "1.12.9",
    126126        "@wordpress/plugins": "6.19.6",
    127127        "@wordpress/preferences": "3.28.6",
     
    131131        "@wordpress/private-apis": "0.33.1",
    132132        "@wordpress/redux-routine": "4.51.1",
    133         "@wordpress/reusable-blocks": "4.28.8",
     133        "@wordpress/reusable-blocks": "4.28.9",
    134134        "@wordpress/rich-text": "6.28.4",
    135135        "@wordpress/router": "0.20.1",
     
    143143        "@wordpress/viewport": "5.28.1",
    144144        "@wordpress/warning": "2.51.1",
    145         "@wordpress/widgets": "3.28.8",
     145        "@wordpress/widgets": "3.28.9",
    146146        "@wordpress/wordcount": "3.51.1",
    147147        "backbone": "1.5.0",
Note: See TracChangeset for help on using the changeset viewer.