WordPress.org

Make WordPress Core


Ignore:
Timestamp:
07/30/2008 06:48:03 AM (12 years ago)
Author:
westi
Message:

Include only valid plugins. Props guillep2k and xknown, fixes #6871 for 2.6.1

File:
1 edited

Legend:

Unmodified
Added
Removed
  • branches/2.6/wp-settings.php

    r8471 r8500  
    422422    if ( is_array($current_plugins) ) {
    423423        foreach ($current_plugins as $plugin) {
    424             if ('' != $plugin && file_exists(WP_PLUGIN_DIR . '/' . $plugin))
     424            if ( '' != $plugin && 0 == validate_file($plugin) && file_exists(WP_PLUGIN_DIR . '/' . $plugin) )
    425425                include_once(WP_PLUGIN_DIR . '/' . $plugin);
    426426        }
Note: See TracChangeset for help on using the changeset viewer.