Make WordPress Core

{31} Tickets in the Formatting component (222 matches)

Arguments
​Create a new ticket
  • Active tickets in the Formatting component
  • Grouped by workflow and sorted by type, summary
  • Accepted tickets have an '*' appended to their owner's name

Results (101 - 200 of 222)

← 1 2 3 →

Tickets Awaiting Review (32 matches)

Ticket Summary Owner Priority Severity Milestone Type Workflow Modified
#46329 sanitize_text_field after 5.1 update should account for __toString() methods normal normal Awaiting Review enhancement 8 years ago
#46188 esc_html does not have support for multiline output. esc_br_html or line-breaking parameter for esc_html is missing normal normal Awaiting Review enhancement has-patch 20 months ago
#44906 Include greek accent characters on "remove_accents" function normal minor Awaiting Review enhancement dev-feedback 8 years ago
#43810 Apostrophe issue normal normal Awaiting Review defect (bug) has-patch 3 months ago
#43394 wpautop inserts extraneous line breaks if hard return around commented content normal normal Awaiting Review defect (bug) 6 years ago
#43313 wptexturise uses the wrong curly quote after a closing link tag normal normal Awaiting Review defect (bug) 8 years ago
#43205 Allow filtering the list of characters to be replaced by wptexturize normal normal Awaiting Review feature request 8 years ago
#43156 _walk_bookmarks(): please add the link id as HTML id attribute. normal normal Awaiting Review enhancement 9 years ago
#43155 Formatting bug with ampasands - WooCommerce Layered Nav normal normal Awaiting Review defect (bug) 9 years ago
#43010 Attribute Name Escape normal normal Awaiting Review enhancement needs-unit-tests 10 days ago
#42182 esc_js must escape U+2028 and U+2029 normal normal Awaiting Review defect (bug) has-patch 9 years ago
#41458 Class gets stripped out when inserting a link in author biography box normal normal Awaiting Review enhancement 9 years ago
#41422 Need replace_filter() function for improved Just In Time filter adjusment normal normal Awaiting Review enhancement 9 years ago
#41304 Bad protocol sanitization in KSES for URLs NOT RFC 3986 compliant normal normal Awaiting Review defect (bug) 12 days ago
#40933 Improvements for get_file_data() function normal normal Awaiting Review enhancement has-patch 9 years ago
#40569 next_post_link parameters $format and $link, have default values that produce awkward to use output normal normal Awaiting Review enhancement 9 years ago
#40528 Title with ascii paragraph separator is not being filtered on post save normal normal Awaiting Review defect (bug) has-patch 13 months ago
#40324 make_clickable doesn't work if url stands after an even number off spaces normal normal Awaiting Review defect (bug) 10 years ago
#40191 Multiline post content with `<` as first character becomes malformed normal normal Awaiting Review defect (bug) 9 years ago
#40045 HTML code entered using "Text" mode gets garbled normal normal Awaiting Review defect (bug) 10 years ago
#39847 force_balance_tags not properly balancing < with <strong> and </strong> normal normal Awaiting Review defect (bug) 2 years ago
#39724 Defining custom validation callbacks for tag/attribute values in wp_kses() normal normal Awaiting Review enhancement 9 years ago
#39674 Special characters are encoded in the database, for site settings options normal normal Awaiting Review enhancement 10 years ago
#39190 RSS feed not valid: U+001A or 0x1a normal normal Awaiting Review defect (bug) 8 years ago
#39188 Wrapping paragraph tags around 'Read More' link stripped out of custom post type normal normal Awaiting Review defect (bug) 8 years ago
#39153 Bug in wp_html_split with unclosed PHP tag (or HTML tag <) normal normal Awaiting Review defect (bug) needs-unit-tests 9 years ago
#37672 wpautop adds a closing p-tag without an opening p-tag normal normal Awaiting Review defect (bug) has-patch 9 months ago
#35201 Mobile email validation normal normal Awaiting Review enhancement 10 years ago
#33204 kses $allowedposttags should support microdata normal normal Awaiting Review enhancement 8 years ago
#30495 Unicode character U+000B is not removed by sanitize_file_name normal normal Awaiting Review defect (bug) has-patch 9 days ago
#29910 esc_attr does not properly deal with json_encode normal normal Awaiting Review enhancement 9 years ago
#22402 Stripping non-alphanumeric multi-byte characters from slugs normal normal Awaiting Review enhancement dev-feedback 13 months ago

Tickets Needing Feedback (14 matches)

#64284 Convert times/multiplication symbol (×) into the letter "x" when sanitizing titles for slugs normal minor Future Release defect (bug) close 2 months ago
#55962 Upgrade `sanitize_hex_color()` to CSS Color Level 4 pbearne normal normal Future Release enhancement dev-feedback 3 years ago
#55257 map_deep() function incompatibility with incomplete objects in PHP 8.0+ normal major Future Release defect (bug) dev-feedback 3 years ago
#50855 sanitize_file_name function not working as expected if there is '%20' in filename audrasjb* normal normal Future Release defect (bug) dev-feedback 4 years ago
#47164 map_deep in formatting.php do not handle null-byte normal critical Future Release defect (bug) dev-feedback 4 years ago
#44793 remove_accents() doesnt escape all versions of "i" SergeyBiryukov normal normal Future Release defect (bug) dev-feedback 7 years ago
#36397 add_query_arg doesn't work with numbered html entities normal normal defect (bug) dev-feedback 7 years ago
#26759 New Generic Sanitize Functions for Core normal normal enhancement close 15 months ago
#25021 Improve sanitize_title_with_dashes % removal normal normal defect (bug) dev-feedback 16 months ago
#19100 Introduce esc_color() normal normal Future Release enhancement dev-feedback 7 years ago
#17491 Make is_email() compliant with RFC5322 (updated by RFC6854) normal minor Future Release defect (bug) needs-unit-tests 15 months ago
#11678 wpautop() fails on uppercase closing tags normal normal defect (bug) dev-feedback 7 years ago
#2833 wpautop breaks style and script tags low normal Future Release defect (bug) dev-feedback 3 years ago
#2691 HTML comments in posts aren't handled properly. normal normal Future Release defect (bug) needs-unit-tests 19 months ago

Tickets with Patches (37 matches)

#64552 wp_trim_words fails with certain charsets in the Excerpt normal normal Future Release defect (bug) has-patch 7 months ago
#64151 Improve maintainability and robustness of sanitize_title_with_dashes() normal normal Future Release enhancement has-patch 6 months ago
#63864 Support RFC 2047 MIME-decoding / improve `wp_iso_descrambler()` low normal Future Release enhancement has-patch 14 months ago
#61501 KSES Allow more custom data attributes to align with browsers dmsnell normal normal Future Release enhancement has-patch 3 months ago
#60979 safecss_filter_attr() should support query strings with "&amp;" as used by Gutenberg normal normal Future Release defect (bug) has-patch 12 days ago
#60319 PHPUnit test for wp_spaces_regexp normal normal Future Release enhancement has-patch 20 months ago
#60300 PHPunit Test for wp_staticize_emoji_for_email normal normal Future Release enhancement has-patch 20 months ago
#58902 add_query_arg() should esc_url_raw() REQUEST_URI normal normal Future Release defect (bug) dev-feedback 16 months ago
#55996 the get_the_block_template_html call all the same functions as the the_conent filter so they are run twice normal normal Future Release defect (bug) dev-feedback 2 years ago
#54488 wp_filter_nohtml_kses does not remove HTML comments audrasjb normal normal Future Release defect (bug) dev-feedback 12 days ago
#52820 Possible logic error in wp_trim_excerpt() SergeyBiryukov normal normal Future Release defect (bug) dev-feedback 2 months ago
#49484 Add option 'OR' to wp_sprintf_l() SergeyBiryukov normal normal Future Release feature request has-patch 6 years ago
#47594 Add nbsp symbol codes to convert throught sanitize_title SergeyBiryukov* normal minor Future Release enhancement has-patch 5 years ago
#46791 esc_url() adding http:// to a relative URL to parent directory '../pathname/' normal normal Future Release defect (bug) has-patch 9 days ago
#45702 make_clickable() doesn't handle linked text being a URL with spaces within it low trivial Future Release defect (bug) has-patch 4 months ago
#43785 wptexturize fails to skip JavaScript if code contains < normal normal Future Release defect (bug) has-patch 2 months ago
#38656 wpautop incorrectly handling paragraphs within block elements normal normal Future Release defect (bug) has-patch 8 months ago
#37077 Replacing one variable handler for another to ensure proper conditional check occurs 100%. normal trivial defect (bug) has-patch 7 years ago
#33924 sanitize_html_class valid characters normal normal Future Release defect (bug) dev-feedback 4 years ago
#32787 make_clickable filter johnjamesjacoby normal normal Future Release enhancement has-patch 21 months ago
#29882 wptexturize: quotes inside quotes curling incorrectly normal normal defect (bug) has-patch 7 years ago
#29807 add support for picture element and srcset attribute on img in wp_kses adamsilverstein normal normal Future Release defect (bug) has-patch 2 days ago
#27350 Invalid HTML Output normal normal Future Release defect (bug) has-patch 2 years ago
#27270 Validation for leading/trailing periods, or consecutive periods in email addresses is only done on the domain section normal normal defect (bug) has-patch 7 years ago
#25108 is_email() function validates email with domain that just has 1 character after dot normal normal defect (bug) has-patch 2 weeks ago
#24225 Improve regular expressions when matching attributes miqrogroove normal normal enhancement needs-unit-tests 7 years ago
#24157 safecss_filter_attr doesn't allow rgb() in inline styles normal normal Future Release defect (bug) has-patch 2 years ago
#23308 make_clickable problem with multiple "Punctuation URL character" normal normal defect (bug) dev-feedback 7 years ago
#22330 Optimize regexes to remove protocol from URL normal normal enhancement needs-unit-tests 15 months ago
#21537 Email address sanitisation mangles valid email addresses normal normal defect (bug) dev-feedback 4 years ago
#18549 wp_texturize incorrectly curls closing quotes after inline HTML end tags miqrogroove normal normal Future Release defect (bug) has-patch 4 months ago
#18330 Add a Class functionality to wpautop() normal normal enhancement has-patch 3 years ago
#17923 add_query_arg() should encode values normal normal defect (bug) has-patch 7 years ago
#17433 localhost is not accepted as email domain normal normal Future Release defect (bug) has-patch 9 years ago
#12084 allow preserving HTML in the_excerpt (specify allowed tags for strip_tags in wp_trim_excerpt) normal normal enhancement has-patch 6 months ago
#10823 Bad handling of ampersand in post titles normal normal defect (bug) has-patch 7 years ago
#6297 Unbalanced tags across more and nextpage tags normal normal Future Release defect (bug) has-patch 10 days ago

Unpatched Bugs (17 matches)

#40202 wpautop bad code normal normal Future Release defect (bug) 8 weeks ago
#36775 Shortcode stripping on frontend normal normal defect (bug) 7 years ago
#36712 Paragraph tags removed from div elements if script tag is present normal normal defect (bug) 7 years ago
#36124 Format: Aside next to an embedded video, removes player and only displays URL normal normal defect (bug) 7 years ago
#34994 HTML5 elements reformatted poorly switching between Visual & Text editors normal normal defect (bug) 7 years ago
#34592 wptexturize interprets apostrophe at end of word as closing single quote normal normal defect (bug) 7 years ago
#34407 esc_url() cannot handle a relative URL containing a : character (IPv6) normal normal defect (bug) 7 years ago
#34039 shortcode_parse_atts() no longer parses embedded html fragments normal normal defect (bug) 7 years ago
#33840 wpautop damages inline script normal normal defect (bug) 7 years ago
#33629 Post excerpts have become WAY too long after updating to WP 4.3, please fix. normal normal defect (bug) has-patch 7 years ago
#33553 Bug with Linebreak before figcaption, fixed and then revert to make a fix elsewhere normal normal defect (bug) 7 years ago
#33466 wpautop breaks multi-line textarea content miqrogroove normal normal defect (bug) 7 years ago
#32867 Wordpress replaces HTML entities for angle brackets in titles, breaking HTML validation normal normal defect (bug) 7 years ago
#32729 WP sanitize + (plus) and other mathematic symbols as nothing instead of dash separator normal normal defect (bug) 7 years ago
#32193 Large (custom) resolution emoticons are being shrunk to 12x12 normal normal defect (bug) 7 years ago
#31695 Enclosing oEmbed using `embed_oembed_html` is generating invalid HTML normal normal defect (bug) needs-unit-tests 7 years ago
#30597 wp_filter_post_kses mangles URLs with colons in them normal normal defect (bug) needs-unit-tests 7 years ago
← 1 2 3 →
Note: See TracReports for help on using and creating reports.