WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#10000 closed defect (bug) (worksforme)

unable to see (or activate) plugins copied manually into wp-content/plugins/

Reported by: helened Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.6
Component: General Keywords: plugin
Focuses: Cc:

Description

Unable to see (or activate) any plugin that is manually copied into "wp-content/plugins/" directory...unless another plugin is installed afterwards using the "Add New" selection or after 2 hours has passed (cron takes that long to reread "wp-content/plugins/ and update "wp_options" apparently).

To reproduce bug: 1) download a new plugin that contains multiple files onto your PC, 2) unzip new plugin, 3) "FTP" new plugin folder to your web server and put it in "/www-root-folder/my-wordpress-path/wp-content/plugins/", 4) in browser, load www.my-site.com/my-wordpress-path/wp-admin/plugins.php, 5) new plugin is NOT listed.

To fix (IMHO): 1) have "plugins.php" reread "wp-content/plugins/" directory every time it is loaded, or 2) add a button "[refresh/reread plugins list]" that rereads the contents of "wp-content/plugins" and updates "wp-options" whenever it is clicked.

FYI. This might be the same bug reported in ticket#9649.

Change History (1)

comment:1 dd325 years ago

  • Milestone Unassigned deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Are you running a custom Object cache? I suspect you are, And it hasn't been updated to use the 2.6+ functionality of global non-persistant groups (Which WordPress uses for several things)

Check your object cache file for the function wp_cache_add_non_persistent_groups.

this works for me under a correctly configured trunk.

Note: See TracTickets for help on using tickets.