WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 15 months ago

#10010 closed defect (bug) (worksforme)

Pings and Trackbacks are not working

Reported by: rioch Owned by: jmulley
Milestone: Priority: normal
Severity: normal Version: 2.8
Component: Pings/Trackbacks Keywords: reporter-feedback
Focuses: Cc:

Description

I have a blog hosted on my own website. The installation is fresh and the only plugins installed are askimet and stats. I wrote a post that links a post in another wordpress blog, and the trackback doesn't appear to have worked. Neither does my post appear in their comments nor my post (in edit mode) show that the trackback has been pinged. I get no errors reported.

This bug seems to be both recurring and caused by many issues (well, there are many suggestions for fixing it, some even including chmod'ing to 777!).

This forum post seems to be the most accurate in describing the problem, and the most recent:

http://wordpress.org/support/topic/233046?replies=28

Change History (56)

comment:1 Denis-de-Bernardy5 years ago

  • Component changed from General to Pings/Trackbacks
  • Keywords needs-testing needs-patch added
  • Milestone changed from Unassigned to 2.8
  • Severity changed from normal to major

comment:2 Denis-de-Bernardy5 years ago

  • Keywords dev-feedback added

blocker?

comment:4 jmulley5 years ago

  • Owner set to jmulley
  • Status changed from new to assigned
  • Version set to 2.8

What is the website you trackbacked and the link to your post?

comment:5 jmulley5 years ago

  • Status changed from assigned to accepted

comment:6 hakre5 years ago

It would be good to have a way to reproduce. I tried a smaller scenario and the test failed:

1.) Setup a WordPress Trunk Version.
2.) Create the second blogbost containing a link to the first blogpost
3.) Check for the Trackback in the first blogpost.

The Test fails, when the Trackback does not appear. The Test is successfull, if the Trackback does appear.

In my case the Test failed against current SVN.

comment:7 follow-up: jmulley5 years ago

@hakre: WordPress has been coded to stop users trackbacking own posts, so it actually is successful.

comment:8 hakre5 years ago

I'm doing the posts as admin, so it should trackback anytime because admin can do things for other users.

comment:9 hakre5 years ago

Detailling the Testcase:

# Setup a WordPress Trunk Version.
# Create a new user with at least the right to add a new post (e.g. author)
# Login as the new user.
# Create the second post on the blog containing a link to the first post ("Hello world!").
# Check for the trackback in comments of the first blogpost.

The Test fails, when the Trackback does not appear. The Test is successfull, if the Trackback does appear.

In my case the Test failed against current SVN.

@jmulley: Please test yourself and use the information you gained in the test to give feedback and - if you like - argument as a second step. Thanks for your feedback anyway.

comment:10 in reply to: ↑ 7 hakre5 years ago

Replying to jmulley:

@hakre: WordPress has been coded to stop users trackbacking own posts, so it actually is successful.

That is new to me. I use trackbacks to my own posts a lot to have posts automatically cross-linked over the blog. That helps for providing usefull links for visitors. It's a WordPress Blog (2.6.x I assume) and it works pretty well.

comment:11 jmulley5 years ago

@hakre, I just tested it and your right, it don't work. Seems we have a problem.

And the thing that stops trackbacking your own site was actually hard coded myself. Woops.

comment:12 jmulley5 years ago

Just updating to the current SVN. Clean install.

comment:13 jmulley5 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

Just tried trackbacking localhost to live blog, works 100%. Please check comments for trackbacks that have been stopped.

comment:14 jmulley5 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:15 jmulley5 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:16 hakre5 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Can not confirm. Test still fails. Still At revision 11529. Still fails. I made a really clean install. Database completely dropped on your side?

comment:17 jmulley5 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

Yes. I used this site: http://www.tamba2.org.uk/wordpress/TestTrack/ to test trackbacks. Make a post on your blog. Login to http://www.tamba2.org.uk/wordpress/TestTrack/wp-admin/ with the username 'TT' and the password 'tester' and make a new post. In Send Trackbacks To, put your blog post's trackback URL. (/trackback/) Then, publish the post. Login to your administration panel and in comments, approve the trackback recieved.

comment:18 Denis-de-Bernardy5 years ago

  • Milestone 2.8 deleted

comment:19 Denis-de-Bernardy5 years ago

reporter might have been relying on trackback auto-detection.

comment:20 follow-up: hakre5 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

@jmulleey: ok. now I see the problem. the blog you test against ist Version 2.7.1. I test against the current SVN. Do you have the ability to test against current SVN?

comment:21 in reply to: ↑ 20 jmulley5 years ago

Replying to hakre:

@jmulleey: ok. now I see the problem. the blog you test against ist Version 2.7.1. I test against the current SVN. Do you have the ability to test against current SVN?

It is from 2.7.1 to 2.8 BETA 1. Does it make a difference?

comment:22 Denis-de-Bernardy5 years ago

yes, it can. the transports aren't necessarily the same, and about 700 tickets have been closed since.

comment:23 hakre5 years ago

  • Severity changed from major to blocker

Raise this to blocker. Trackbacks must work in the 2.8 release version.

comment:24 dd325 years ago

  • Keywords reporter-feedack added; needs-patch trackback pingback ping removed

Confirmed 2.8 -> 2.8 working.

Confirmed 2.8 -> 2.7.1 working.

Confirmed 2.7.1 -> 2.8 working.

Thats running on a live blog here: http://test.dd32.id.au/test1/ & http://test.dd32.id.au/test2/ (Test2 was originally a 2.8 svn co, but it got switched to 2.7.1 for testing).

Since trackbacks/pingbacks run through cron, are you sure Cron's firing? I think thats going to be the entire root cause with these issues since the code has hardly been touched in the last few major releases (The trackback/pingback code that is)

comment:25 follow-up: hakre5 years ago

dd32, have you tested against the same blog (not two blogs with the same version) as well? my test is trackbacking between posts in the same blog.

Is there a plugin to debug cron entries?

comment:26 dd325 years ago

No, I've not tested a pingback to the same blog. IIRC they're disabled by default?

comment:27 in reply to: ↑ 25 scribu5 years ago

  • Milestone set to 2.8

Replying to hakre:

Is there a plugin to debug cron entries?

Just put this code somewhere:

add_action('admin_footer', 'cron_debug');

function cron_debug() { var_dump(get_option('cron')); }

comment:28 dd325 years ago

Trackbacks to self work.

Pingbacks to self seem to work (In that theres a pingback enqued, WP's rate-limiter of pings is delaying it from happening)

comment:29 dd325 years ago

Theres only one case where they dont work that i've found, Thats when pinging another blog where the post ID there (and they're not using rewrite) is the same as the current post, since url_to_postid() doesnt check to see if the URL is a local one first (It was never designed to check for remote url's).

Everything else seems to be firing properly to me, Try defining ALTERNATE_WP_CRON and see if that makes a difference, define('ALTERNATE_WP_CRON', true)

comment:30 hakre5 years ago

dd32 have you done my test step by step? i tried the debug information you were talking about: two related entries after submit of the post: do_pings and do_generic_ping. is that ok? still have no trackbacks.

comment:31 hakre5 years ago

tried alternate_wp_cron define, did not change a thing. linking to an existing post of another user does not trackback it on current svn in a fresh install.

comment:32 dd325 years ago

  • Milestone changed from 2.8 to 2.9
  • Severity changed from blocker to normal

dd32 have you done my test step by step?

I cant see anything you've posted worthwhile testing.

I've tested each combination, and cant fault it.

Moving to 2.9 based on the fact its working for me at least, and that theres no actual solution yet. Whatever your problem is, Its not going to be fixed in the 2.8 release.

comment:33 rioch5 years ago

Sorry for the late reply but I wasn't receiving emails that the ticket had been updated.

My blog is at: www.black-projects.org/blog with the following post http://www.black-projects.org/blog/2009/06/raising-children-as-individuals/ linking to the following external blog post http://thebeattitude.com/2009/05/31/according-to-my-daughter-superman-is-better-than-god/.

@Denis-de-Bernardy
Initially I had the link in the post and in the trackback field (with /trackback appeneded). It didn't work. I then realised that wordpress can auto detect trackbacks, so removed it from the trackback field; still didn't work.

If you would like me to run a plugin on my blog to get more information, please just ask.

comment:34 hakre5 years ago

@dd32: Test is:

  1. Setup a new WordPress based on Trunk Version.
  2. Login as Admin
  3. Create a new user with at least the right to add a new post (e.g. author)
  4. Login as the new user.
  5. Create the second post on the blog containing a link to the first post ("Hello world!").
  6. Check for the trackback in comments of the first blogpost.

The Test fails, when the Trackback does not appear. The Test is successfull, if the Trackback does appear.

In my case the Test failed against current SVN.

@dd32: This is the acceptance Test I meant. It's worth testing to get valuable information. It does not make sense that you test something else because it is not possible to compare the outcome.

comment:35 rioch5 years ago

The latest post on my blog (http://www.black-projects.org/blog/2009/06/yearning-for-an-alternative/) contains a link to another post on my blog (last link in the post) and no trackback is showing.

If necessary I can install the SVN version but that won't happen until tomorrow evening (if possible).

comment:36 dd325 years ago

People need to be specific when talking about trackbacks, and pingbacks, since they're 2 completely different things (Well, Same thing, Just different protocol)

WordPress auto-pings links which are in the content of the post. WordPress does not auto-trackback, You have to enter the trackback URL into the trackback field.

@hakre: Yes, That is what i did (Except that i was testing under a admin user, which honestly makes no difference, unless it works for you under an admin account). I've reported that it WORKS, I'm not saying that it doesn't work for you, Just saying that the pingback/trackback code works as expected under my current setup, under the cases outlined. Now you can figure it out why its not working, Or wait for someone who's reproduced it not working to figure out why. Thats all.

comment:38 Denis-de-Bernardy5 years ago

closed #10040 as dup as well.

the two tickets highlighted use-cases with Serendipity that didn't work (for incoming and outgoing trackbacks)

comment:39 utele5 years ago

  • Cc utele added

comment:40 Denis-de-Bernardy5 years ago

  • Keywords reporter-feedback added; reporter-feedack needs-testing dev-feedback removed

comment:41 Denis-de-Bernardy5 years ago

seems no-one is agreeing on a clean means to reproduce...

comment:42 rioch5 years ago

I've installed wordpress 2.8 and the problem still exists. Looking at the database table, the columns related to ping show:

  • ping_status = Open
  • to_ping = empty (not the literal string value; there is nothing there)
  • pinged = empty (not the literal string value; there is nothing there)

These values are the same for all posts including revisions, regardless of whether they contain pingbacks or trackbacks.

comment:43 rioch5 years ago

There hasn't been much activity. Has my new information not helped?

I have also read that the problem may be due to cron not running. Is there a way I can test this? Does anyone have any other ideas for how I can come to the root cause?

comment:44 jmulley5 years ago

Pings are different from trackbacks. Cron doesn't have to run..

comment:45 dd325 years ago

Pings are different from trackbacks. Cron doesn't have to run..

Pings/Trackbacks both run via Cron dont they? I think that changed in a recent version.

comment:46 stephenju5 years ago

  • Cc stephenju added

comment:47 follow-up: hakre5 years ago

Has some else (next to DD32) tried my test-case to reproduce? Is that test valid to test for trackbacks? (this ticket is about trackbacks, not pings).

comment:48 follow-up: bi0xid5 years ago

Trackbacks doesn't work in a recently moved to 2.8 blog. It worked while in 2.7. It was auto-upgrade.

comment:49 in reply to: ↑ 48 hakre5 years ago

Replying to bi0xid:

Trackbacks doesn't work in a recently moved to 2.8 blog. It worked while in 2.7. It was auto-upgrade.

How did you test? Please describe step by step. Have you tested on a blank install as well?

comment:50 in reply to: ↑ 47 ; follow-up: rioch5 years ago

Replying to hakre:

Has some else (next to DD32) tried my test-case to reproduce? Is that test valid to test for trackbacks? (this ticket is about trackbacks, not pings).

I have tried this on my blog and it fails. Also, I should mention that when I opened the ticket I mixed up the terminology on what a trackback/pingback is. The problem occurs with both - pingbacks and trackbacks.

comment:51 in reply to: ↑ 50 hakre5 years ago

  • Summary changed from Trackbacks are not working to Pings and Trackbacks are not working

Replying to rioch:

[...] I should mention that when I opened the ticket I mixed up the terminology on what a trackback/pingback is. The problem occurs with both - pingbacks and trackbacks.

Thanks for clarification. I changed the summary to reflect that.

comment:52 janeforshort4 years ago

  • Milestone changed from 2.9 to Future Release

Punting as we are in beta (freeze) and there does not seem to be a clear solution in this thread.

comment:53 follow-up: Denis-de-Bernardy4 years ago

This might be related to a cron that's not working with curl, or timing out, or something like that.

Could any of the reporters give it a shot with the Core Control plugin turned on in order to monitor what's going on over in the cron?

comment:54 in reply to: ↑ 53 hakre4 years ago

Replying to Denis-de-Bernardy:

This might be related to a cron that's not working with curl, or timing out, or something like that.

Could any of the reporters give it a shot with the Core Control plugin turned on in order to monitor what's going on over in the cron?

Well that problem you talk about is newer then when this ticket was actually opened. But a good hint for current tests anyway.

My main problem in debugging this is that I can not loose the feeling that those which are reporting it as working aren't actually exactly following the acceptance test I suggested. Until that is not done, this will not show a clear image of the problem. Please keep in mind that the acceptance test is based on a new, clear install with an unintialized database.

I'd like to see this re-tested for current trunk now to get a current state. Curl problems should be fixed in trunk (if curl is used anyway).

comment:55 Denis-de-Bernardy4 years ago

I'm increasingly leaning towards a cron problem. In the past couple days, I've been receiving pings that were sent up to two weeks before they showed up for moderation.

comment:56 westi15 months ago

  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

There hasn't been any activity on this ticket for over 3 years and we have made a number of improvements to the cron etc which probably resolved the underlying causes here.

Closing this ticket as Works for Me.

Note: See TracTickets for help on using tickets.