WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#10019 closed defect (bug) (fixed)

Custom Taxonomy edit page Javascript-add doesnt work

Reported by: dd32 Owned by: filosofo
Milestone: 2.8 Priority: normal
Severity: normal Version: 2.8
Component: Taxonomy Keywords: has-patch
Focuses: Cc:

Description

The Custom Taxonomy edit page doesnt work as intended with Javascript additions.

The issue is that the taxonomy is not passed to _tag_row().

Code for testing:

add_action( 'init', 'theme_taxonomies', 5 );

function theme_taxonomies() {
	register_taxonomy( 'people', 'post', array( 'hierarchical' => false, 'label' => 'People', 'query_var' => true, 'rewrite' => true ) );
}

Then visit the edit-tag.php?taxonomy=people and attempt to add a new item.

Attachments (1)

10019.diff (533 bytes) - added by dd32 5 years ago.

Download all attachments as: .zip

Change History (2)

dd325 years ago

comment:1 ryan5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [11512]) Pass taxonomy to_tag_row() when adding tags via ajax. Props dd32. fixes #10019

Note: See TracTickets for help on using tickets.