WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#10070 closed defect (bug) (invalid)

Firefox Crashes when trying to install plugin or theme

Reported by: links2funblog Owned by: dd32
Milestone: Priority: normal
Severity: major Version: 2.8
Component: Upgrade/Install Keywords: reporter-feedback needs-testing
Focuses: Cc:

Description

I don't know whether this is a Firefox or a Wordpress problem but when I try to install some plugins or themes Firefox crashes and the Mozilla error reporter appears. I am running Firefox 3.0.10 and I have submitted the error report thingy to Mozilla.

Change History (9)

comment:1 @Denis-de-Bernardy6 years ago

  • Component changed from Administration to Upgrade/Install
  • Milestone changed from Unassigned to 2.9
  • Owner set to dd32

comment:2 follow-up: @Simek6 years ago

  • Keywords needs-testing need-patch reporter-feedback added; plugin theme install removed

Can you give link to CrashReport? You find it by typing "about:crashes" in FF address bar.

comment:3 @sivel6 years ago

There were a few people in the IRC channel the other day with this problem. They all seemed to be running 3.0.10 in Windows Vista with several extensions installed. Downgrading to an earlier Firefox release such as 3.0.8 resolved the problem. I tested myself with a clean FF 3.0.10 install on Vista and could not reproduce the problem.

The problem being reported was when clicking the install link, Firefox would crash before showing the Thickbox overlay.

comment:4 @azaozz6 years ago

  • Keywords needs-testing need-patch removed

Cannot reproduce it either, seems to work properly in both Firefox 3.0.10 and 3.5-nightly. Can you post the error message and what add-ons are active?

comment:5 in reply to: ↑ 2 @links2funblog6 years ago

Replying to Simek:

Can you give link to CrashReport? You find it by typing "about:crashes" in FF address bar.

Heres the report

Add-ons: battlefieldheroespatcher@ea.com:4.0.17.0,{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}:0.9.84,{c4d362ec-1cff-4ca0-9031-99a8fad7995a}:1.10.2009050501,{2fa4ed95-0317-4c6a-a74c-5f3e3912c1f9}:2.1.041,firebug@software.joehewitt.com:1.3.3,firecookie@janodvarko.cz:0.8,{3d7eb24f-2740-49df-8937-200b1cc08f8a}:1.5.10,{000a9d1c-beef-4f90-9363-039d445309b8}:0.5.21.0,notebook@google.com:1.0.0.22,keepass@hostnameintitlebar:0.1,{3b56bcc7-54e5-44a2-9b44-66c3ef58c13e}:0.8.5.6,Inquisitor@yahoo:1.1,{CAFEEFAC-0016-0000-0007-ABCDEFFEDCBA}:6.0.07,{CAFEEFAC-0016-0000-0011-ABCDEFFEDCBA}:6.0.11,jqs@sun.com:1.0,LogMeInClient@logmein.com:1.0.0.395,{75CEEE46-9B64-46f8-94BF-54012DE155F0}:0.3.8,netvideohunter@netvideohunter.com:0.4.2,{7E7165E2-0767-448c-852F-5FA8714F2C37}:1.0.2,ubiquity@labs.mozilla.com:0.1.8,{e968fc70-8f95-4ab9-9e79-304de2a71ee1}:0.6.11,searchrecs@veoh.com:1.5.1,web@veoh.com:1.4,{c45c406e-ab73-11d8-be73-000a95be3b12}:1.1.6,foxmarks@kei.com:3.1.0,{972ce4c6-7e08-4474-a285-3208198ce6fd}:3.0.10,{00352F14-3F76-4e4d-ACFF-9976D7E4B3B9}:0.6.6,nasanightlaunch@example.com:0.6.20090524,redshift_V2@shift-themes.com:2.95
BuildID: 2009042316
CrashTime: 1244510254
InstallTime: 1241919975
ProductName: Firefox
SecondsSinceLastCrash: 39159
StartupTime: 1244509709
Theme: redshift_V3
URL: http://www.links-2-fun.com/wp-admin/plugin-install.php?tab=search&type=tag&s=Post
Vendor: Mozilla
Version: 3.0.10

I am not running vista just xp

comment:6 @ShaneF6 years ago

  • Keywords needs-testing added

Needs to be re-tested. 3.0.11 just came out.

comment:7 @Denis-de-Bernardy6 years ago

  • Keywords wontfix added

testing report 18

comment:8 @Denis-de-Bernardy6 years ago

  • Keywords wontfix removed

comment:9 @dd326 years ago

  • Milestone 2.9 deleted
  • Resolution set to invalid
  • Status changed from new to closed

I'm closing as invalid.

No other reports, and this is a Firefox bug anyway.. The contents of the page shouldnt cause it to crash no matter what.

Note: See TracTickets for help on using tickets.