Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#10098 closed defect (bug) (worksforme)

Turbo failed

Reported by: csseur3 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.8
Component: Administration Keywords: reporter-feedback
Focuses: Cc:



with WP 2.8, when i go to the "tools" menu, i have this error:

Download of 'http://www.example.com/wp-includes/js/tinymce/wp-tinymce.php?c=0&ver=3241-1141' failed, status code 403.

I try to deactivate and re-activate Turbo, but same effect.

Change History (11)

comment:1 @dd326 years ago

  • Keywords reporter-feedbacl added

403 is a Permission denied error.

Can you check if you can browse to that URL in your browser? Can you check its filesystem chmod settings via ftp?

Was it an automatic upgrade, or manual?

comment:2 @csseur36 years ago

It's a manual upgrade, and i try to chmod in 777 the tinymce folder, but nothing effect.

There is a 403 in my browser when i try to check it.

comment:3 @dd326 years ago

  • Keywords reporter-feedbacl removed
  • Milestone 2.8.1 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Then its not a WordPress bug.. Since that file doesnt contain anything that could cause a 403..

Can you access the file /wp-includes/js/tinymce/wp-tinymce.js ?
If not, I'd suggest deleting the entire tinymce folder and uploading it again.

comment:4 @csseur36 years ago

Yes, i can access all of the files of folder, but not the /wp-tinymce.php?c=0&ver=3241-1141

comment:5 @csseur36 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

There is no solution?

Trust me when i say there is no error with my server! The 403 is just because i deactivate the listing of folder (in apache2), in reality, it's a 404 with /wp-tinymce.php?c=0&ver=3241-1141 , so tinymce have a problem in WP 2.8

comment:6 @Denis-de-Bernardy6 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

please re-open with steps to reproduce consistently

comment:7 @csseur36 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

First blog:
WP 2.7.1 FR upgrade to WP 2.8 US, and to WP2.8 FR > WP would like the file wp-tinymce.php?c=1&ver=3241-1141 = 403

Second blog:
WP 2.7.1 FR upgraded to WP 2.8 FR > WP would like the file wp-tinymce.php?c=1&ver=3241-1141-vvq6.2.3line3 = 200 OK

So, what is the problem for the first blog? What can i do? :(


comment:8 @Denis-de-Bernardy6 years ago

  • Keywords reporter-feedback added
  • Milestone set to 2.8.1

Well, the versions don't seem identical even though they presumably should. Does the problem still occur if you take a test blog from 2.7.1 FR to 2.8 US, and then to 2.8 FR?

comment:9 @azaozz6 years ago

wp-tinymce.php will always output a js file regardless of the query string, perhaps see if it has been uploaded properly and is not zero bytes or wrong permissions, etc.

comment:10 @sivel6 years ago

A 403 is a 403. A 404 does not get converted to a 403 because directory indexing is disabled. Directory indexing just prevents you from seeing a file list when browsing to the directory. It would not cause a 403 unless the file or the apache configuration is preventing access to the file.

As anyone in the httpd IRC channel would say:

Whatever the problem, step one is to look in the error log (and any other logs that may apply, such as suexec, mod_rewrite, or mod_security).

Once you can confirm why the 403 is being returned, which the apache error log will tell you, we can rule this out as being a WordPress issue.

I have tested that this file is accessible on all 28 servers that I run WordPress 2.8 on currently and none of them are experiencing this problem.

For the time being we will leave this ticket open until you give us the snippet of apache error log related to this 403.

comment:11 @ryan6 years ago

  • Milestone 2.8.1 deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

Closing. Reopen with requested feedback.

Note: See TracTickets for help on using tickets.