WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10106 closed defect (bug) (invalid)

wp-config-sample.php missing closing PHP tag

Reported by: sojweb Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: has-patch
Focuses: Cc:

Description

The config sample file included with 2.8 is missing the closing PHP tag. Someone just needs to stick it back in.

Attachments (1)

wp-config-sample.php.2.diff (328 bytes) - added by sojweb 6 years ago.
wp-config-sample.php with closing PHP tag

Download all attachments as: .zip

Change History (6)

@sojweb6 years ago

wp-config-sample.php with closing PHP tag

comment:1 @filosofo6 years ago

  • Resolution set to invalid
  • Status changed from new to closed
  • Version 2.8 deleted

This is a feature, not a bug.

First, closing PHP tags are optional.

More importantly, since this is a user-edited file, it's highly likely that someone's text editor will add a line break after the closing tag, causing error messages that aren't immediately traceable. Leaving off the closing tag avoids that headache.

comment:2 @filosofo6 years ago

By user-edited, I mean that people copy wp-config-sample.php and edit it as wp-config.php

comment:3 @demetris6 years ago

Maybe it would be a good idea to put a comment it its place, so that people don’t think that something is missing or that the file is incomplete? Something like:

//  END OF FILE

Just a thought...

comment:4 @Denis-de-Bernardy6 years ago

  • Milestone Unassigned deleted

comment:5 @sojweb6 years ago

I'll be damned. Learn something every day. Thanks.

Note: See TracTickets for help on using tickets.