WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 11 years ago

#10123 closed defect (bug) (wontfix)

Automatic upgrade cannot locate wp-content

Reported by: link2caro Owned by: dd32
Milestone: Priority: low
Severity: minor Version: 2.8
Component: Upgrade/Install Keywords:
Focuses: Cc:
PR Number:

Description

I encounter on some server this message: "Unable to locate WordPress Content directory (wp-content)."

Should we replace the button "Upgrade automatically" with a text saying that "This server does not support the automatic upgrade function" when this type of issue is detected, so that people don't try to click it?

It's just a proposition :)

Change History (10)

#1 @dd32
11 years ago

WordPress doesnt know that its going to fail until the user tries it at least once.

Ideally, It'd be great to fully support every setup imaginable.

What is the environment that this occurs under?

PHP Version, Filesystem Paths, FTP? What PHP Extensions? what path do you see wordpress in when you connect via FTP, Even what FTP server(&version) is being used.

#2 @link2caro
11 years ago

I have some friends who use free hosting at byethost and 000webhost.
I tried on byethost, to force direct_mode (is this the name?) and it passes, so there is a test when choosing the method to update that fails (with the default WordPress installation).

Here is the info: http://wptest.wpvn.co.cc/wordpress/

#3 @link2caro
11 years ago

If you want to test the host:

ftp.wpvn.co.cc
Username: wpvnc_3605119
Password: wptest

http://wptest.wpvn.co.cc/wordpress/wp-admin
Username: wptest
Password: wptest

---

I just remark about the path:
ftp path to wordpress is: /wptest.wpvn.co.cc/htdocs/wordpress

Could this path is the problem?

#4 @Denis-de-Bernardy
11 years ago

  • Keywords needs-patch added
  • Milestone changed from Unassigned to 2.9

#5 @Denis-de-Bernardy
11 years ago

  • Type changed from enhancement to defect (bug)

#6 @lloydbudd
11 years ago

  • Keywords reporter-feedback needs-repo added; needs-patch removed
  • Milestone changed from 2.9 to Future Release
  • Version set to 2.8

link2caro, please focus on describing the symptom first and then as much detail as possibly about the cause of the problem. It looks like you even forgot to include the version of WordPress.

When we have a handle on the cause of this issue lets start a new ticket.

#7 @link2caro
11 years ago

Sorry about the version, this issue affects both 2.7 and 2.8
The symptom is that Installer, Upgrader keeps saying it cannot locate the wp-content (fresh installation)

What should I give you more as information?

#8 @dd32
11 years ago

What should I give you more as information?

See my first comment here

#9 @Denis-de-Bernardy
11 years ago

  • Milestone changed from Future Release to 2.9

#10 @dd32
11 years ago

  • Keywords reporter-feedback needs-repo removed
  • Milestone 2.9 deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Closing as Wontfix. If you're having issues with WP not being able to find the folders it needs, Please open a new ticket for that issue, providing the details mentioned in this comment: http://core.trac.wordpress.org/ticket/10123#comment:1

Note: See TracTickets for help on using tickets.