WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#10127 closed defect (bug) (duplicate)

User roles not translated

Reported by: pavelevap Owned by: nbachiyski
Milestone: Priority: normal
Severity: normal Version:
Component: I18N Keywords: reporter-feedback
Focuses: Cc:

Description

Hi, after upgrade to Wordpress 2.8 and using Czech translation, user roles (Administrator, Editor, etc.) are not displayed in Czech, but in original English. Before upgrade it was everything in Czech.

Change History (6)

comment:1 ryan5 years ago

  • Keywords reporter-feedback added

Have you updated your translation for 2.8? The way context is added to those strings changed, so an updated translation is needed.

comment:2 pavelevap5 years ago

Yes, of course. You can download Czech version for Wordpress 2.8 from Codex and try it... Everything works well except 5 user roles which stay in English...

comment:3 pavelevap5 years ago

  • Cc pavelevap@… added

Also on some websites (PHP 5.2.9), after using Czech version, only "Right Now" widget is loaded and then nothing (only many Javascript errors in Firefox console). After deactivating Czech version everything works well...

comment:4 pavelevap5 years ago

And on this websites there is also problem with Timezone selection - there is nothing to select and page ends after this selection, so it is not possible to Update changes, because there is no button.

comment:5 demetris5 years ago

I can confirm this issue.

Out of 4 installations on 4 different servers, the issue (untranslated user-role names) occurs in two.

I cannot see any patern at the moment.

comment:6 ryan5 years ago

  • Milestone 2.8.1 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Let's track this with #10270

Note: See TracTickets for help on using tickets.