WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10130 closed defect (bug) (fixed)

Suggested tags list adds partial tag when selecting suggested tag with Enter key

Reported by: phthomas Owned by: azaozz
Milestone: 2.9 Priority: normal
Severity: normal Version: 2.8
Component: JavaScript Keywords: tag, post
Focuses: Cc:

Description

In 2.7.1 when entering tags for your post, you were able to type a partial tag, use the up or down arrow keys to select the suggested tag and press enter with the desired suggestion highlighted and it would add that tag to your post.

In 2.8 when you use the same method, it places the partial typing in the tags list and places the suggestion in the tag entry box rather than replacing the partial typing altogether.

Example:
If I wanted to use the tag "foobar" for my post and I entered "foo" in the entry box and WP listed "foobar" in the suggestions, I would use the arrow keys to highlight "foobar" in the list and press enter to select "foobar".

In 2.7 & 2.7.1, this action would clear the tag entry box and place "foobar" in the tag list.

In 2.8, this action adds "foo" to the tag list and places "foobar," in the tag entry box.

Browser: Firefox 3.0.10
OS: Ubuntu 9.04

Change History (7)

comment:1 ryan5 years ago

  • Milestone changed from Unassigned to 2.8.1

Confirmed with FF3.5b99.

comment:2 Denis-de-Bernardy5 years ago

  • Component changed from General to JavaScript
  • Owner set to azaozz

comment:3 phthomas5 years ago

  • Cc peter@… added

This bug does not appear to manifest itself in Google Chrome 2.0.172.31 on Windows.

comment:4 robertaccettura5 years ago

I've noticed this as well in Firefox 3.5. It's quite annoying since it's a change in expected behavior.

comment:5 scribu5 years ago

  • Milestone changed from 2.8.5 to 2.9
  • Summary changed from WordPress 2.8 Posting - Suggested tags list adds partial tag when selecting suggested tag with Enter key to Suggested tags list adds partial tag when selecting suggested tag with Enter key

comment:6 demetris5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Closing as fixed:

I can reproduce in WP 2.8.4 with Fx 3.5.2.

I cannot reproduce in 2.9-rare r12045 with Fx 3.0.14, Fx 3.5.2, or Fx 3.7a1pre.

Interestingly, Fx 3.7a1pre seems to be OK with WP 2.8.4.

comment:7 azaozz5 years ago

Yes, fixed in [12022] along with some other minor bugs.

Note: See TracTickets for help on using tickets.