WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 3 years ago

#10133 closed defect (bug) (fixed)

Dashboard feeds not loading

Reported by: pavelevap Owned by:
Milestone: 2.9 Priority: high
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

Hi, after fresh install of Wordpress 2.8, there is a problem with Dashboard - no chance to click Screen Options and Dashboard is not loaded to the end. On other pages in administration this problem disappears, but when you return to Dashboard, here it is again. In Firefox console there are also many errors... We encountered this problem on one web, so we tried another clear install on subdomain and you can look at it.

http://test.herma.org

login: admin pass: admin

Attachments (2)

dashboard-ajax-load-rss.patch (6.0 KB) - added by azaozz 5 years ago.
dashboard-ajax-load-rss-2.patch (13.9 KB) - added by azaozz 5 years ago.

Download all attachments as: .zip

Change History (42)

comment:1 azaozz5 years ago

  • Keywords reporter-feedback added

All seems to be working ok, also would suggest to change the admin password and not post it publicly.

comment:2 pavelevap5 years ago

  • Cc pavelevap added

No, problem persists. When I logged in for the first time, everything was OK. But then Dashboard is not loaded to the end and Javascript does not work (for example it is not possible to click Screen Options). When you go everywhere except Dashboard then everything works well, but as soon as you click on Dashboard, problem is here...

Somebody changed this password, so we had to change it once again and after password change Dashboard worked. But only once. When I click Add Post and then return back to Dashboard, problem was here again. It is strange. Can I send you somewhere new login to test it?

We tried it with IE8, Firefox 3.x and Opera and problem is still here (Google Gears not used). Before upgrade from 2.7.1 was everything OK. Thank you for your help...

comment:3 nyliferocks5 years ago

I am using Firefox and the Dashboard only shows loading.... in the blog dashboard area. If I use Internet explorer the dashboard works and it no longer shows loading. So the issue is only with Firefox. I am using WPMU 2.7

comment:4 pavelevap5 years ago

No, this problem appears in all browsers for me. When I return back to Dashboard after more then (around) 24 hours, then Dashboard is loaded as the whole (but Blog, News and Plugin widgets there is only "Loading"). When I click somewhere else and then return back to Dashboard, then it is not loaded to the end (missing footer), no Javascript works, but Blog, News and Plugin widgets are loaded correctly... Please, could you test it somebody - I can give you login info (it is fresh install with no change)...

comment:5 ryan5 years ago

This could be related to #10162. Are there any errors in the error log?

comment:6 pavelevap5 years ago

No, it is not related. There is no anonymous comment (only the first generated one from wordpress.org). I tried to apply updated dashboard.php from this ticket, but problem persist. I am not allowed to see error log, but I will try to write to my webhoster for some of them...

comment:7 hallsofmontezuma5 years ago

  • Cc hallsofmontezuma added

Check the PHP memory for the process. I've noticed on some servers it asking for a ton of memory when loading simplepie.

comment:8 pavelevap5 years ago

It is fresh install, no plugin, english version and memory_limit = 60MB.

comment:9 ryan5 years ago

See also #10147

comment:10 ryan5 years ago

Just in case that SimplePie change helps, can you try the 2.8.1 nightly build?

http://wordpress.org/nightly-builds/wordpress-2.8-latest.zip

comment:11 pavelevap5 years ago

I tried to apply http://core.trac.wordpress.org/changeset/11600, but no change after clearing cache in IE8 and Firefox 3.x. You can test it with demo:demo.

comment:12 ryan5 years ago

Your demo site just tells us that the page stopped execution before it could finish, probably due to a fatal error. Are there errors in the server's error log?

comment:13 follow-up: pavelevap5 years ago

I upgraded to WordPress 2.8.1-alphabeta-11601, but problem persists. Dashboard was loaded fully in the morning, but with missing plugins, News, etc (only with message Loading). In incoming links there were missing URL and there were following error:

Warning: file_get_contents() [function.file-get-contents]: Unable to access http: in /var/www/web5/herma.org/test.herma.org/wp-includes/class-feed.php on line 97

Warning: file_get_contents(http:) [function.file-get-contents]: failed to open stream: No such file or directory in /var/www/web5/herma.org/test.herma.org/wp-includes/class-feed.php on line 97

RSS Error: file_get_contents could not read the file

But this error is probably due to your testing? I added URL of Google Blog Search and everything is the same as yesterday. We wrote to our webhoster (we have no direct access to logs) and he wrote back, that there is no httpd error log for this subdomain, so there is probably no problem...

comment:14 in reply to: ↑ 13 azaozz5 years ago

Replying to pavelevap:
Can you try with the above patch? There seems to be something "flaky" about that server, at different times it outputs different amount of the dashboard HTML but never outputs it in full. Perhaps it has something that limits CPU time use, memory use, etc.

comment:15 pavelevap5 years ago

Patch applied, Dashboard is now fully loaded, great. Only widgets with News and Plugins have not loaded content, you can look at it. I added phpinfo() here: http://test.herma.org/phpi.php, but I do not see anything strange...

comment:16 azaozz5 years ago

The second patch has more workable js.

Don't see anything strange in the phpinfo too apart from it being version 5.1.2 that is from 3 1/2 years ago. Perhaps that version has a bug that is triggered by SimplePie. The Dashboard stops working when SimplePie is used.

comment:17 pavelevap5 years ago

I tried this patch, but no change... Maybe we can test it with PHP 5.1.2 on localhost?

comment:18 WraithKenny5 years ago

I've had this problem, but only after activating plugins or themes. Certain plugins, OpenID for example (sometimes only after activating a plugin following OpenIDs activation), with disrupt the dashboard (options don't fold out, and widgets don't load all the way). Some plugins interfere with the general settings page. Atleast one theme had the same issues. Tested on many different blogs (established and fresh install including database), but all of which on mosso/rackspace cloud servers. I didn't have these issues on a local dev machine though. I haven't had the issue on a fresh install until after activating a troubled plugin. Therefor, I'm not sure weither this is a WordPress bug or many plugins with the same or related issue.

comment:19 WraithKenny5 years ago

Additional info: Buffet Framework interferes with the Dashboard. 2.8 and 2.9rare

activated Akismet, Hello Dolly, OpenID with no problem, then WordPress.com Stats and IntenseDebate: Dashboard broken. Deactivated OpenID, now it works. This is consistent on 2.8 and the nightly.

WP Security Scan: on 2.8 with only Akismet, Hello Dolly (deactive), WP Stats, and WP Security Scan active, the Settings General page stops loading at timezone. on nightly 2.9rare, I couldn't replicate bug.

comment:20 azaozz5 years ago

(In [11613]) Always load the Dashboard RSS widgets with AJAX, see #10133 for trunk

comment:21 azaozz5 years ago

(In [11614]) Always load the Dashboard RSS widgets with AJAX, see #10133 for 2.8

comment:22 pavelevap5 years ago

Updated to latest changeset 11614, but it looks similar to second patch. No change...

comment:23 WraithKenny5 years ago

this might be related to the memory issue addressed with 2.8.1 beta.

My issue was solved with upgrading to the beta, but upgrading plugins fail unless disabling plugins on a blog with many plugins. Dashboard widgets also fail unless plugin count reduced ("500 internal server error" in firebug). javascript menu animations do still work tho :)

possibly relate: A client's (high traffic) blog on a mosso/rackspace cloud server was slowed to a crawl today do to MySQL issues that I believe may have been resolved on there end. Is it possible that was do to a similar memory problem?

So if I understand properly, this and many other open tickets are a result of Wordpress requiring more memory then is available on the server, is this right?

comment:24 WraithKenny5 years ago

/wp-admin/index.php?edit=dashboard_secondary#dashboard_secondary
and
/wp-admin/index-extra.php?jax=dashboard_secondary
are causing the 500 errors. Works when only when certain plugins are running.

Also in our php_error.log.

[22-Jun-2009 19:58:46] PHP Warning: Cannot modify header information - headers already sent in /...local-root.../domain.com/web/content/wp-includes/functions.php on line 2754

[22-Jun-2009 19:54:44] PHP Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 386925 bytes) in /...local-root.../domain.com/web/content/wp-includes/wp-db.php on line 450

comment:25 azaozz5 years ago

Looks like SimplePie can take a lot of memory or even crash on some specific server configurations and/or PHP versions. The normal WordPress admin memory usage with 3-4 (not memory hungry) plugins is about 11 - 12MB, well below the 32MB that is set as maximum.

Unfortunately when that happens the page doesn't work properly as most JavaScript is supposed to load in the footer and is missing. The above patch is mainly a workaround for this.

Add something like:

<p><?php echo memory_get_usage(true); ?></p>

to admin-header.php and admin-footer.php to see the memory used at the beginning and end of any admin page.

comment:26 follow-up: pavelevap5 years ago

I upgraded to beta1, but problem persists.
Memory usage:

  • header: 11976896
  • footer: 12118936

So, it looks like it is not memory related issue for me...

comment:28 pavelevap5 years ago

No, there is still "Loading" for Plugins and two Feeds widgets in IE8 (and nothing displayed in Firefox 3). Only Incoming links started to show default text "This dashboard widget queries Google Blog Search so that when..." instead of Loading message.

comment:29 in reply to: ↑ 26 azaozz5 years ago

Replying to pavelevap:

I upgraded to beta1, but problem persists.
Memory usage:

  • header: 11976896
  • footer: 12118936

So, it looks like it is not memory related issue for me...

The memory usage is about right but the dashboard doesn't load SimplePie directly any more, it uses AJAX. What happens when you try to configure the RSS widgets?

comment:30 pavelevap5 years ago

I can configure them without problem, but result is only "Loading". You can test it with demo:demo.

comment:31 scribu5 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Working fine.

comment:32 pavelevap5 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

It is not working fine for me. There is messagge "Loading..." on many Dashboard widgets and data are not loaded properly...

comment:33 scribu5 years ago

  • Keywords SimplePie added; reporter-feedback removed
  • Summary changed from Dashboard not loaded to Dashboard feeds not loading

Then it's an issue with SimplePie.

comment:34 WraithKenny5 years ago

  • Cc WraithKenny added

My brother noticed on his blog that his wp_options table widget values where all messed up, and his widgets were disappearing. He tried Tadlocks widget reset plugin but it didn't work.

http://justintadlock.com/archives/2009/03/03/widgets-reset-wordpress-plugin

Comments at the bottom from flora and Kevin Newman are the relevant ones.

He didn't find the cause of why the values were skewed, but then I remembered this ticket, and I think they are related somehow, but I leave that to the more knowledgeable people here (now that I see this is still open ;)

comment:35 ryan5 years ago

[12193] may help.

comment:36 pavelevap5 years ago

Great. I do not know which changeset changed it, but after upgrade to latest trunk (with Beta Tester plugin) all feeds are loaded properly. I will try my other website later (it is on production server and I will wait for official 2.9), but we can close this ticket, I guess. Thank you...

comment:37 scribu5 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:38 nacin3 years ago

It's tempting to try the original implementation again: #16927.

comment:39 kmfj13 years ago

  • Keywords needs-patch added; SimplePie removed
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version set to 3.1.1

I removed my feed URL from the dashboard incoming links. This caused a file not found error in file_get_contents in class-feed.php on about line 97. file_get_contents can't open the non-existent URL, which causes the error. If the script used file_exists before file_get_contents this should fix the issue? This is not a SimplePie issue but the extended class: WP_Feed_Cache

I changed to:

if(!file_exists($url)){

$this->error = 'the file doesn\'t exist could not read the file';
$this->success = false;

}
else{

if ( ! $this->body = file_get_contents($url) ) {

$this->error = 'file_get_contents could not read the file';
$this->success = false;

}

}

This fixed the issue?

Last edited 3 years ago by kmfj1 (previous) (diff)

comment:40 ocean903 years ago

  • Keywords needs-patch removed
  • Resolution set to fixed
  • Status changed from reopened to closed
  • Version 3.1.1 deleted

kmfj1, please open a new ticket after testing it again with WordPress 3.2 beta or trunk.

Note: See TracTickets for help on using tickets.