Make WordPress Core

Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#10155 closed defect (bug) (invalid)

ScreenOptions does not save for Dashboard

Reported by: link2caro's profile link2caro Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.8
Component: UI Keywords: reporter-feedback
Focuses: Cc:

Description

Is this normal that the screenoptions for Dashboard cannot be saved?
all of my sites have this issue.

Every setting for Dashboard works, it just does not save.

Change History (11)

#1 @Denis-de-Bernardy
15 years ago

  • Milestone changed from Unassigned to 2.8.1
  • Priority changed from high to normal

#2 @Denis-de-Bernardy
15 years ago

works fine here. what browser are you using?

#3 @ryan
15 years ago

  • Keywords reporter-feedback added

#4 @ryan
15 years ago

Can you use firebug to look at the AJAX requests that are sent when a screen option is changed? The response section should have "1".

#5 @link2caro
15 years ago

AJAX reponse: -1

Browser: Firefox (Mac/Win), Chrome, Safari (Win)

Widgets work, but all the draggable components do not save the settings.

#6 @ryan
15 years ago

-1 means either the current user could not be determined or some invalid data was passed. Can you dump the Post section from firebug? Right click and "Copy location with parameters".

#7 @link2caro
15 years ago

/wp/wp-admin/admin-ajax.php?action=closed-postboxes&closed=&closedpostboxesnonce=097cde5b5e&hidden=dashboard_recent_drafts%2Cdashboard_primary%2Cdashboard_secondary&page=dashboard

/wp/wp-admin/admin-ajax.php?action=closed-postboxes&closed=&closedpostboxesnonce=097cde5b5e&hidden=dashboard_primary&page=dashboard

/wp/wp-admin/admin-ajax.php?action=closed-postboxes&closed=&closedpostboxesnonce=097cde5b5e&hidden=dashboard_quick_press%2Cdashboard_recent_drafts%2Cdashboard_primary%2Cdashboard_secondary&page=dashboard

#8 @link2caro
15 years ago

This is from another site that works, this makes me think that is due to the plugin of integration with vBulletin with map the the member system.

/wp-admin/admin-ajax.php?_ajax_nonce=d8fdab4000&action=meta-box-order&order%5Bcolumn3%5D=dashboard_quick_press&order%5Bcolumn4%5D=&order%5Bnormal%5D=dashboard_right_now%2Cdashboard_recent_comments%2Cdashboard_incoming_links%2Cdashboard_plugins&order%5Bside%5D=dashboard_recent_drafts%2Cdashboard_primary%2Cdashboard_secondary&page=dashboard&page_columns=3

#9 @azaozz
15 years ago

Was this caused by a plugin? If not, action=closed-postboxes is when you open or close particular postbox, action=meta-box-order is when you move a postbox or change the number of columns. Are they all returning AJAX response: -1? Need to look at the POST that causes admin-ajax.php to return -1, all POST requests above seem correct.

#10 @link2caro
15 years ago

  • Resolution set to invalid
  • Status changed from new to closed

This is caused by a plugin, there is no user table for the options to be saved.

#11 @Denis-de-Bernardy
15 years ago

  • Milestone 2.8.1 deleted
Note: See TracTickets for help on using tickets.