WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 8 years ago

#10156 closed enhancement (duplicate)

Empty (blank) search redirects to index page

Reported by: Elpie Owned by: ryan
Milestone: Priority: normal
Severity: normal Version: 2.8
Component: Query Keywords: accessibility WCAG
Focuses: Cc:

Description

If a user sends an empty search in the frontend WordPress loads the index page, without warning and without sending an error notice. This contravenes WCAG2.0 success criteria 3.3.1 & 3.3.3. See: http://www.w3.org/TR/2008/PR-WCAG20-20081103/#minimize-error

This was raised on the forums 6 months ago: http://wordpress.org/support/topic/218195

While this is a usability issue and the lack of an error message can cause problems for all users, it is also a significant accessibility issue - particularly for blind users who get no warning that the page has changed.

In the backend there is no redirect, but nothing happens. An error message should be displayed to alert the user that they need to input a search term.

This is not new behaviour in 2.8 but the increased attention to accessibility as well as to usability makes this omission more obvious.

Attachments (1)

10156.diff (703 bytes) - added by dhruvbaldawa 10 years ago.
The issue is resolved

Download all attachments as: .zip

Change History (6)

#1 @Denis-de-Bernardy
11 years ago

  • Component changed from General to Query
  • Keywords needs-patch added
  • Milestone changed from Unassigned to Future Release
  • Owner set to ryan
  • Type changed from defect (bug) to enhancement

@dhruvbaldawa
10 years ago

The issue is resolved

#2 @dhruvbaldawa
10 years ago

  • Keywords changed from needs-patch accessibility, WCAG to needs-patch accessibility WCAG
  • Resolution set to fixed
  • Status changed from new to closed

#3 @dhruvbaldawa
10 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

#4 @Elpie
9 years ago

  • Cc Elpie added

#5 @SergeyBiryukov
8 years ago

  • Keywords needs-patch removed
  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.