WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#10178 closed feature request (invalid)

URLs are forced to use the WordPress base URL again.

Reported by: onekopaka Owned by: ryan
Milestone: Priority: low
Severity: normal Version:
Component: Permalinks Keywords: reporter-feedback close
Focuses: Cc:

Description

URLs in WordPress 2.8 were not forced to be based off the URL in the settings. Now in WordPress 2.9-rare, you are forced to use the value in the settings again. I find this very annoying, and would prefer that the old behavior be used.

Change History (7)

comment:1 @ryan6 years ago

  • Keywords reporter-feedback added; URLs settings removed

Could you provide context and steps to reproduce?

comment:2 @onekopaka6 years ago

My blog is at http://oks.verymad.net/~onekopaka/blog/ and http://oks.kicks-ass.net/~onekopaka/blog/. The latter is the setting for the URL in the WordPress dashboard. Any link produced by WordPress is a full URL using the URL defined in the settings. In my opinion, WordPress should use either relative URLs or use the current domain ($_SERVERHTTP_HOST?).

comment:3 @Denis-de-Bernardy6 years ago

  • Keywords close added

This is invalid, no? Best I'm aware, WP has always used absolute urls due to the RSS feeds.

comment:4 @onekopaka6 years ago

no, at some point during 2.7 (or 2.8) development (I run my blog out of the svn trunk), links were based off the same domain as the page that was being viewed, so if I were viewing http://oks.verymad.net/~onekopaka/blog/, the link for the page with the permalink twitter-updatesh would be linked to http://oks.verymad.net/~onekopaka/blog/twitter-updatesh/, but now it is linked to http://oks.kicks-ass.net/~onekopaka/blog/twitter-updatesh/.

comment:5 @Denis-de-Bernardy6 years ago

WP uses absolute urls based on get_option(home), always. Any chances you might be using a plugin that broke at some point?

comment:6 @Denis-de-Bernardy6 years ago

If you look into:

http://core.trac.wordpress.org/log/trunk

there's absolutely nothing between r11549 and r11573 that affects permalinks.

comment:7 @ryan6 years ago

  • Milestone 2.9 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Indeed. WP has always used absolute URLs and will continue to do so for the foreseeable future.

Note: See TracTickets for help on using tickets.