WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#10200 closed defect (bug) (wontfix)

Cron not running

Reported by: firmdot Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.8
Component: Cron API Keywords: cron, schedule
Focuses: Cc:

Description

Since upgrading to 2.7 and now 2.8 we're unable to schedule posts. The error is missed schedule.

There are a number of people having this issue too, check page 3 for the most recent reports:

http://wordpress.org/support/topic/221086/page/3

Change History (7)

comment:1 follow-up: @azaozz6 years ago

  • Priority changed from highest omg bbq to normal
  • Severity changed from critical to normal

There are some changes to wp-cron in 2.8, see [10521]. Use the native cron if available or try adding

define('ALTERNATE_WP_CRON', true);

to wp-config.php.

comment:2 @hailin6 years ago

This is maybe a result of options cache stomping on each other.

In my debugging, I've noticed that options cache (cron) is seriously out of sync with the corresponding db records, especially when the user shedules multiple future posts within a few minutes. But it does seem to be caused by some changes in 2.8, because I saw this issue resurfaced again in the past several days.

comment:3 @ryan6 years ago

See also #10104 for possibly related transport issues.

comment:4 in reply to: ↑ 1 @tflight6 years ago

  • Cc tflight added

Replying to azaozz:

There are some changes to wp-cron in 2.8, see [10521]. Use the native cron if available or try adding

define('ALTERNATE_WP_CRON', true);

to wp-config.php.

While adding that to my config file did work, it seems to create some funny links. I'm guessing this works by occasionally appending '?doing_wp_cron' to the URL. I've seen a few visitors to my site create links they've seen with that appended to the URL since making that change. And I'm seeing some of those URLs get indexed in Google that way:
http://www.google.com/search?q=inurl:%3Fdoing_wp_cron

comment:5 @ryan6 years ago

  • Milestone changed from 2.9 to Future Release

comment:6 @miqrogroove5 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

This ticket was obsoleted by #11505. Please file new tickets for the 2.9 branch.

comment:7 @sirzooro5 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.