WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#10207 closed defect (bug) (fixed)

Custom Taxonomy Tags not appearing in admin-new/edit-posts-screen

Reported by: F J Kaiser Owned by: filosofo
Milestone: 3.0 Priority: normal
Severity: normal Version:
Component: Taxonomy Keywords: reporter-feedback taxonomy, tag, admin, post
Focuses: Cc:

Description (last modified by Denis-de-Bernardy)

(Didn´t find some similar or related tickets)

How to recreate:

  1. Add for e.g. "Example1" as a new taxonomy.php in the functions.php of your theme, you get a new menu-entry (.wp-submenu) in your "posts" admin-menu named "Example1".
  2. Add a new tag called "Test1" in your "Example1"-taxonomy.
  3. Create a new, or edit some existing post.
  4. Try to get your "Test1"-tag, you created in your taxonomy, from your "Example1"-taxonomy meta-box ...

... you simply don´t have something to call the existing tags. You can only creat new tags.

  • What´s good: When you creat the same "Test1" tag in edit post taxonomy-meta-box, it won´t double the tag.
  • What´s not good: It makes the "Example1" taxonomy Sub-Page obsolete, when you can´t make use out of the tags created there.
  • What could be even better: A sollution that brings all existing tags in one taxonomy into the meta-box at the "edit post" page.

Hope this is no missunderstanding on my side.

Change History (12)

comment:1 Denis-de-Bernardy5 years ago

  • Description modified (diff)
  • Milestone changed from Unassigned to 2.9

comment:2 Denis-de-Bernardy5 years ago

So... if I'm understanding this right, you're saying that the javascript for custom taxonomies in the post editor will not return existing terms in that taxonomy.

comment:3 F J Kaiser5 years ago

yes, that´s the point.

comment:4 F J Kaiser5 years ago

edit: the custom taxonomy-field in the post-editor won´t show
a) existing terms already added at the custom-term submenu
b) existing terms added at another post (or is this just my problem?)

comment:5 ryan4 years ago

  • Milestone changed from 2.9 to 3.0

This saw a litle work in 2.9 but could use some more. Moving to 3.0.

comment:6 F J Kaiser4 years ago

hi ryan, i updated to v2.9 and added a new-custom-taxonomy-tag (within post > "custom-taxonomy-term"). when editing a post, it´s still not possible to find one of the terms you added. maybe it´s because you´ll only find the most popular terms, which can´t get found as long as you have no possiblity to access and use your terms.

i would suggest to not display a list of the most popular, but instead let the editor access all terms in the specific custom-taxonomy. makes a lot more sense to me. until now the custom-taxonomy-feature is pretty useless and getting less attention all over the web(-blog-world).

comment:7 hakre4 years ago

  • Keywords reporter-feedback added

Can you provide a plugin so it's possible to reproduce and test this?

comment:8 hakre4 years ago

Just reviewed again: The latest patch (which I think looks pretty good) does not handle the NULL case, which means, how to deal with the case that there is no template? Is this what it is wanted (drop any template) or should there be the fallback to index.php?

comment:9 hakre4 years ago

Please ignore the last comment it was done in error.

Realted: #9269

comment:10 hakre4 years ago

Another custom taxnonomy related ticket is: #11612

comment:11 dd324 years ago

I cant duplicate this.

  1. Created a new Taxonomy (as flat taxonomy)
  2. Created a Term in that taxonomy "Number 1 Thing Term"
  3. Loaded the add new post page
  4. Typed "Thing" into the Taxonomies box, "Number 1 Thing Term" poped up.
  5. Typed in "Category", Category didnt show up

Seems that #4 and #5 show to me that terms for custom taxonomies are shown, and that terms do not bleed accross Taxonomies.

Can anyone duplicate this on trunk?

comment:12 F J Kaiser4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Updated to 2.9.1 and found everything as "should be". The added Taxonomies are now showing up. We can mark this as "resolved". Thanks.

Note: See TracTickets for help on using tickets.