WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#10241 closed defect (bug) (wontfix)

Pingback fails due to apostrophe in HTML comment?

Reported by: Viper007Bond Owned by: josephscott
Milestone: Priority: normal
Severity: minor Version: 2.8
Component: XML-RPC Keywords: dev-feedback
Focuses: Cc:

Description

My Video Quicktags plugin has had on and off reports about it breaking the sending of pingbacks.

A user of the plugin has reported to me that the issue is due to an apostrophe in an HTML comment inserted into the <head> by my plugin: http://plugins.trac.wordpress.org/changeset/128694

we analysed the Ping Bug of your Plugin. XMLRPC wants to check the page that is pinging and returns the Error 17: "The source URL does not contain a link to the target URL, and so cannot be used as a source."

The Problem is the "'" in <!-- Viper's Video Quicktags line 2651 of Version 6.2.5

When XMLRPC executes "$linea = strip_tags( $linea, '<a>' );" and your Plugin is running only other stuff will show. Not right the Content.

Assuming this was indeed the cause, shouldn't WordPress be smarter than that?

Change History (8)

comment:1 Denis-de-Bernardy5 years ago

  • Milestone changed from Unassigned to 2.9

comment:2 miqrogroove4 years ago

  • Keywords dev-feedback added; needs-patch removed
  • Priority changed from lowest to normal

Since there's no activity on this ticket, I'd like to chime in and confirm the symptoms. I wrote a test case against PHP 5.2.11 and found that this bug is not caused by WordPress.

See background information already available at http://bugs.php.net/bug.php?id=46578

The workaround for OP is to use a back-tick instead of a single quote.

A WP dev should be able to agree and decide between needs-patch or wontfix status.

comment:3 miqrogroove4 years ago

  • Cc miqrogroove@… added

comment:4 lloydbudd4 years ago

  • Milestone changed from 2.9 to 3.0

No patch... bumping out of milestone.

comment:5 miqrogroove4 years ago

  • Milestone changed from 3.0 to 2.9

lloydbudd, punting this ticket doesn't help anyone because it's not a bug in WordPress. If a core dev is willing to consider a code hack, I will gladly write it. Otherwise, please wontfix.

comment:6 Denis-de-Bernardy4 years ago

  • Milestone 2.9 deleted
  • Resolution set to wontfix
  • Status changed from new to closed

based on:

http://bugs.php.net/bug.php?id=46578

it's fixed in the latest php versions.

comment:7 miqrogroove4 years ago

Denis-de-Bernardy, I tested this on PHP 5.2.11 and it is not fixed. Just so we're clear on that point.

Note: See TracTickets for help on using tickets.