WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#10289 closed defect (bug) (worksforme)

Theme preview doesn't work when previewing another page than home

Reported by: kwurzel Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.8
Component: Themes Keywords: reporter-feedback
Focuses: Cc:

Description

In WP 2.8b2, the theme preview doesn't work when you're trying to preview another page than your home page (which is previewed by default).

steps to reproduce:

  1. open theme preview
  2. click an (internal) link to a different page/post/etc.
  3. the default theme is used

I'm not using any caching plugin, my browser cache is cleared and I tried to renew the admin cookie, as advised in #9315.

Change History (9)

comment:1 dd325 years ago

from memory, The links to other pages are supposed to be disabled when previewing to prevent you from browsing around due to that exact problem

comment:2 kwurzel5 years ago

They aren't. :-) Internal links have the same query string, so theoretically it should be possible to browse within the preview. And even if they were, how am I supposed to preview another page than my front?

comment:3 hakre5 years ago

There is no abstraction of the HTTP request with WP, therefore you risk a lot for the preview. It's more or less a game of luck.

But I remember I was previewing other pages then front some time ago.

comment:4 kwurzel5 years ago

  • Cc kwurzel added

It was possible with 2.7.1 before the upgrade.

What do you mean by "no abstraction of the HTTP request with WP"? It's possible to load the preview in a new window/tab, so why shouldn't it work for other pages after clicking a link?

comment:5 hakre5 years ago

For the theme to work (theme = any theme) and there is only one request, you can't properly preview a secondary theme with the one request that there is for the primary theme. that is what I mean with that there is with "no abtration of the HTTP request with WP". To have the preview work properly, at least a secondary request must be done and therefore request at all must be abstracted to handle one or more additional requests.

comment:6 ryan5 years ago

Works fine here.

comment:7 hakre5 years ago

Here as well, with or w/o javasript. I would conside this close as worksforme. Maybe this is theme-related and some theme does not want to gets previewed?

comment:8 hakre5 years ago

  • Keywords reporter-feedback added

comment:9 ryan5 years ago

  • Milestone 2.8.1 deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.