WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#10290 closed defect (bug) (duplicate)

Images uploaded via WLW do not add to Gallery

Reported by: ioni Owned by: josephscott
Milestone: 2.9 Priority: normal
Severity: normal Version: 2.8.5
Component: XML-RPC Keywords: image, attachment, gallery
Focuses: Cc:

Description

If a post is added via Windows Live Writer (notwithstanding, a draft or a New Post), Wordpress does not add the images uploaded to the Gallery (which is did before)

Attachments (1)

wordpress_2.8_metadata_bug.jpg (80.7 KB) - added by cqrt 6 years ago.
Screenshot and commentary of WP Media Gallery after upgrade to WP 2.8.1

Download all attachments as: .zip

Change History (16)

comment:1 @ioni6 years ago

Any ideas?

comment:2 follow-ups: @josephscott6 years ago

I'm pretty sure WLW uploads were never added as part of a post gallery. The methods available for clients (like WLW) to upload files don't provide a means for that file to be associated with a post.

comment:3 in reply to: ↑ 2 @ioni6 years ago

Replying to josephscott:

I'm pretty sure WLW uploads were never added as part of a post gallery. The methods available for clients (like WLW) to upload files don't provide a means for that file to be associated with a post.

Let me assure you that they were - at least in 2.7 this method worked absolutely fine with me (which is why I started the thread - it did work!)

comment:4 in reply to: ↑ 2 @ioni6 years ago

Replying to josephscott:

I'm pretty sure WLW uploads were never added as part of a post gallery. The methods available for clients (like WLW) to upload files don't provide a means for that file to be associated with a post.

I actually am not the only one: http://wordpress.org/support/topic/280687

comment:5 @janeforshort6 years ago

  • Milestone changed from 2.8.1 to 2.8.2

Pushing since 2.8.1 is already in Beta 2 and new investigations will be happen in the next dev cycle.

comment:6 @ioni6 years ago

Bump

comment:7 @cqrt6 years ago

Bump and confirm that Wordpress 2.8 is no longer adding image metadata to posts when post is uploaded via XMLRPC solutions like Windows Live Writer.

@cqrt6 years ago

Screenshot and commentary of WP Media Gallery after upgrade to WP 2.8.1

comment:8 @laullon6 years ago

It happens too if the post is create by the admin UI.

comment:9 @ioni6 years ago

  • Milestone changed from 2.8.3 to Future Release

Next verion, maybe?

comment:10 @josephscott6 years ago

I wonder if this is related to #10521 it might be that WLW is using the enclosure approach to associate the uploaded images with a post (which I hadn't thought of) and that the -1 look up is failing.

comment:11 @josephscott6 years ago

  • Cc josephscott added
  • Component changed from Gallery to XML-RPC
  • Owner set to josephscott

comment:12 @josephscott6 years ago

  • Milestone changed from Future Release to 2.9

comment:13 @ryan5 years ago

  • Milestone 2.9 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

comment:14 @ioni5 years ago

  • Cc ioni added
  • Milestone set to 2.9
  • Version changed from 2.8 to 2.8.5

Dear Joseph,

You changed the status to closed, but the issue is still present (at least with 2.8.6)

comment:15 @nacin5 years ago

It was closed as a duplicate of #10521.

Note: See TracTickets for help on using tickets.