Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#10328 closed defect (bug) (duplicate)

No wp_list_authors output

Reported by: takaitra Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.8
Component: Template Keywords: wp_list_authors
Focuses: Cc:


The template function wp_list_authors gives no output for a specific combination of options.

In order to reproduce this error, call wp_list_authors(hide_empty=1&style=none)

Expected output: A comma separated list of authors who have posted to WordPress.
Actual output: nothing

A fix is to modify line 330 of wp-includes/author-template.php.

Currently: else if ( ! $hide_empty )
Should be: else if ( !($posts == 0 && $hide_empty) )

Change History (1)

comment:1 @michaelh6 years ago

  • Milestone Unassigned deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This is duplicate of #10042 so try the patch attached to that ticket.

Note: See TracTickets for help on using tickets.