Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#10399 closed enhancement (fixed)

Random order of Category List in Add/Edit Link

Reported by: DrWingnut Owned by:
Milestone: 3.0 Priority: low
Severity: trivial Version: 2.8.1
Component: Administration Keywords: link admin has-patch needs-testing
Focuses: Cc:


The add/edit administration link (.../wp-admin/link.php?action=edit&link_id=###) dialog shows the category list in random order. Could this list please be sorted alphabetically by category name for more rapid visual parsing.

Attachments (5)

CategoriesInRandomOrder.jpg (70.1 KB) - added by DrWingnut 6 years ago.
categories-orderby-count.png (11.9 KB) - added by jamierumbelow 6 years ago.
Shows how the category listing is ordered by count
10399-link-cats-sort-by-name.diff (446 bytes) - added by jamierumbelow 6 years ago.
"Fix" for the ticket
10399-sort-by-name.diff (410 bytes) - added by pnettle 6 years ago.
Sort by name
10399-refreshed.diff (495 bytes) - added by chrisscott 6 years ago.

Download all attachments as: .zip

Change History (13)

@jamierumbelow6 years ago

Shows how the category listing is ordered by count

@jamierumbelow6 years ago

"Fix" for the ticket

comment:1 @jamierumbelow6 years ago

  • Keywords has-patch added
  • Milestone changed from Unassigned to 2.8.2
  • Priority changed from normal to low
  • Resolution set to fixed
  • Severity changed from normal to trivial
  • Status changed from new to closed

If you take a look at wp-admin/includes/template.php on Line 610, you can see that it is actually being sorted by the number of links in that category. However, I believe that sorting the categories alphabetically would actually be a better idea, so attached is the diff for that change.

It's up to whoever makes the decisions to decide whether this should be included or not!

comment:2 @johnbillion6 years ago

  • Milestone 2.8.2 deleted
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Type changed from defect (bug) to enhancement

Hey jamierumbelow, thanks for helping improve WordPress! Just for your future reference, a ticket in Trac isn't marked as fixed until the issue is fixed and committed into the WP core.

comment:3 @jamierumbelow6 years ago

Sorry - I think I've done something like that before... I'll remember next time!

comment:4 @Denis-de-Bernardy6 years ago

  • Keywords needs-patch added; has-patch removed
  • Milestone set to 2.9

it needs to be ordered by name imo

@pnettle6 years ago

Sort by name

comment:5 @pnettle6 years ago

  • Keywords has-patch added; needs-patch removed

comment:6 @ryan6 years ago

  • Milestone changed from 2.9 to 3.0

@chrisscott6 years ago

comment:7 @chrisscott6 years ago

  • Keywords needs-testing added

Refreshed patch attached in attachment:ticket:10399:10399-refreshed.diff since this didn't apply cleanly against r13308.

comment:8 @nacin6 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [13313]) Order link categories by name, not count, on Add/Edit Link page. Fixes #10399 props pnettle, chrisscott.

Note: See TracTickets for help on using tickets.