Make WordPress Core

Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#10406 closed defect (bug) (invalid)

wp_timezone_choice in wp-admin/options-general.php breaks page on php 5.3

Reported by: demonicpagan's profile demonicpagan Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.8.1
Component: Date/Time Keywords: timezone, wp_timezone_choice, options, general
Focuses: Cc:

Description

After upgrading the php on my server to php 5.3, I noticed my General Settings in the admin page never displayed and broke the page.

http://temp.stelth2000inc.com/screen/generalsettings.png

Further digging through the code after people mentioning in the support forums about the timezone, I initially removed that section of the page (starting on line 97). Page loaded fine (minus the timezone section due to removal).

I evaluated the if statement (if ( !wp_timezone_supported() ) :) to see what was returned. It returned false leading me to the else statement.

Just placing the code within the else statement where the timezone code originated and reuploading to my server confirmed it was this section of code that was causing some problems.

I didn't have to dissect much further as I found out that by slowly adding things into the table data section, starting with the select box, that this bit was causing problems.

Removing the <select id="timezone_string" name="timezone_string"> & </select> from around the php call and just pasting that itself brought me back to the original issue, page not displaying properly.

I am unable to dissect any further, but I'm gathering that somewhere within the wp_timezone_choice function, something is not working properly.

$tzstring returns America/Chicago on my platform

Attachments (2)

generalsettings.png (27.4 KB) - added by demonicpagan 15 years ago.
Screen shot ... same as link posted
php-5.3.0-systzdata-v5.patch (13.2 KB) - added by demonicpagan 15 years ago.
Patch file from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=535770

Download all attachments as: .zip

Change History (7)

@demonicpagan
15 years ago

Screen shot ... same as link posted

#1 follow-up: @sivel
15 years ago

  • Component changed from Administration to Date/Time
  • Priority changed from high to normal
  • Severity changed from major to normal

The problem is with the timezone_identifiers_list function. I installed PHP 5.3 from the dotdeb repository and found that it caused a seg fault. I talked to some people from ##php and found that it is not a problem with the source distribution but with dotdeb's packaging and possibly with the debian/ubuntu time zone database.

I will let this ticket remain open until I can test more. But it is likely not to be a problem that can be resolved in the WordPress code.

#2 in reply to: ↑ 1 @demonicpagan
15 years ago

Replying to sivel:

The problem is with the timezone_identifiers_list function. I installed PHP 5.3 from the dotdeb repository and found that it caused a seg fault. I talked to some people from ##php and found that it is not a problem with the source distribution but with dotdeb's packaging and possibly with the debian/ubuntu time zone database.

I will let this ticket remain open until I can test more. But it is likely not to be a problem that can be resolved in the WordPress code.

Since I am using this source distro and platform. Are there any steps I could possibly take to fix it. How was it that you determined it to be a seg fault?

#4 @sivel
15 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Since this has been confirmed to be a bug in the Debian PHP/Timezone implementation closing this ticket as invalid.

#5 @Denis-de-Bernardy
15 years ago

  • Milestone Unassigned deleted
Note: See TracTickets for help on using tickets.