Make WordPress Core

Opened 15 years ago

Closed 14 years ago

#10437 closed defect (bug) (fixed)

Taxonomy metabox doesn't respect show_ui parameter

Reported by: michelwppi's profile michelwppi Owned by: dd32's profile dd32
Milestone: 3.0 Priority: normal
Severity: normal Version: 2.8
Component: Administration Keywords: needs-patch
Focuses: Cc:

Description

Since WP 2.3 that introduces powerful taxonomies, as others dev, xili-language plugin use a specific taxonomy to manage languages of post. I observe that in WP 28, dev team decide to display automatically in post edit ui all customized non hierarchical taxonomies (line #296 of edit-form-advanced.php...)...
This introduces some troubles for users because sometime theses taxonomies must be hidden to authors UI or need specific designed admin UI meta boxes (as designed in xili-language)... The selection by property "hierarchical" is too general and inapropriate. (the xili taxonomy here created is not hierarchical) I suggest to introduce a new property in function register_taxonomy() in array args - 'post_admin_display' true by defaut - line #173 of taxonomy.php... And this property can be checked in the loop to add meta boxes of edit-form-advanced.php...
If you agree as I hope, I can provide sources...

Best regards

Attachments (3)

hidden_meta_boxes.patch (312 bytes) - added by prettyboymp 15 years ago.
hidden_meta_boxes2.patch (311 bytes) - added by xibe 14 years ago.
Updated patch.
10437.diff (2.4 KB) - added by scribu 14 years ago.
add show_box parameter

Download all attachments as: .zip

Change History (21)

#1 @dd32
15 years ago

  • Keywords needs-patch added
  • Milestone changed from 2.8.2 to Future Release
  • Version set to 2.8

+1 to the idea of having a flag to prevent the displayment of meta boxes.

At present i think you can do it by setting the label to false, however i'm not sure thats the most elegant way of going about it, certainly isn't obvious to plugin authors.

Milestone: Future release pending patch for enhancements, Current-trunk upon patch being added for consideration, point release back-porting at commiters discretion. (Generic reply for when I change the milestone)

#2 @michelwppi
15 years ago

  • Cc michelwppi added

As you invite me - I add 'label' and set it to false when registering of taxonomy - as here in xili-language plugin :

/* add new taxonomy in available taxonomies */
		register_taxonomy( TAXONAME, 'post',array('hierarchical' => false, 'label'=>false, 'rewrite' => false, 'update_count_callback' => array(&$this,'_update_post_lang_count')));

And it works... Thanks

In edit-form-advanced.php today :
As we say in french "c'est vraiment tordu" because creating a meta box with a false label and in fact don't display the box ... I think it was better and logical to limit the loop before adding the meta box...
Enhancement needed and adding doc about this property label (cited 6 times in taxonomy.php)

Best regards
Michel
http://dev.xiligroup.com


#3 @prettyboymp
15 years ago

  • Cc mpretty@… added
  • Keywords has-patch added; needs-patch removed

I probably should have created a different ticket for this since the problem I was actually trying to solve was hiding the slug metabox for custom post_types. However, when searching before submitting, I found that the same patch would fix this issue and added it here. This should allow custom taxonomies to be hidden during editing while filling other needs of hiding meta_boxes.

#4 @scribu
15 years ago

  • Milestone changed from Future Release to 2.9

#5 @ryan
15 years ago

  • Milestone changed from 2.9 to Future Release

#6 @prettyboymp
14 years ago

  • Milestone changed from Future Release to 3.0

I realize this is too late to make 2.9 now, but I'd like to see it early 3.0. It is only a filter being added.

#7 @mikeschinkel
14 years ago

  • Cc mikeschinkel@… added

@xibe
14 years ago

Updated patch.

#8 @xibe
14 years ago

  • Keywords dev-feedback added

Patch updated to latest trunk.

#9 @nacin
14 years ago

  • Owner set to dd32
  • Status changed from new to assigned

Pretty sure this is now handled by show_ui in register_taxonomy()?

Do we need a way to control different aspects of a custom taxonomy UI? (panels, meta boxes, etc.)

The filter here would simply control its default show/hide state via screen options. That still allows it to be shown. I don't think that's what we're going for here.

#10 @Denis-de-Bernardy
14 years ago

  • Keywords reporter-feedback added; has-patch dev-feedback removed
  • Milestone changed from 3.0 to 3.1

two new parameters (show_ui and public) got introduced by #10773. I think we should use either or both of those, if there is anything left to fix.

itching to close this as dup. punting pending feedback instead.

@scribu
14 years ago

add show_box parameter

#11 @scribu
14 years ago

  • Keywords has-patch added; reporter-feedback removed

I think it's common for taxonomy-heavy sites to want to keep the default tag/category administration screens, but use custom metaboxes.

Therefore, a show_box parameter makes sense.

See 10437.diff

#12 @scribu
14 years ago

  • Keywords commit added
  • Milestone changed from 3.1 to 3.0

Maybe this can make it into 3.0 ?

#13 @dd32
14 years ago

Is there a reason the show_ui flag couldnt be used here?

The use-case for wanting to hide the default Management page, whilst showing on the Post-management page would be rare. In the cases where someone wishes for their taxonomy to use the internal metabox, they'd just have to call the add_meta_box() function themselves.

I think show_ui should be used for both.. But i'd be open to objections to that.

#14 @scribu
14 years ago

  • Keywords commit removed
  • Summary changed from Post edit UI : better control and choice of add_meta_box of registered post taxonomies to Taxonomy metabox doesn't respect show_ui parameter
  • Type changed from enhancement to defect (bug)

Checking the show_ui flag when adding the metabox would be a step in the right direction.

#15 @scribu
14 years ago

  • Keywords needs-patch added; has-patch removed

#17 @ryan
14 years ago

(In [13946]) Move wp-ajax_add-tax hook back to registration. Reverts part of [13924]. see #10437

#18 @nacin
14 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.