WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#10442 closed defect (bug) (fixed)

Custom Image Size Settings

Reported by: matkaleena Owned by:
Milestone: 3.0 Priority: normal
Severity: normal Version: 2.8.1
Component: Media Keywords: custom image sizes, custom image settings
Focuses: Cc:

Description

On a Page or Post, when using Edit Image on an image that has been resized through the Advanced Image Settings > Size > Width and/or Height, the original image size values are shown as default in the Width and Height boxes.

I would expect the custom values I've entered and saved last time (for this picture, on this page/post) to be the ones showing up, not the original size values.

Very closely related to this problem is:

On a Page or Post, when using Edit Image through the Advanced Image Settings > Size

If I enter a custom value only in the Height field, and leave the Width field empty, it won't save the Height value entered and it also won't save any changes made to Edit Image Caption value on the Edit Image tab.

Change History (5)

#1 @scribu
8 years ago

  • Milestone changed from Unassigned to 2.9

#2 @designsimply
8 years ago

Confirmed. Image dimensions are not remembered in the Edit Image > Advanced Settings tab if only one dimension is entered. The dimensions are only remembered if both a width and a height are set.

Example:
http://screencast.com/t/S23Qtxcw8

Note: Screencast was created with wpcom r21121 on 2009-11-05.
Also tested with wporg r12146 on 2009-11-05 with the same results.

Can we make it so that the dimensions are remembered even if only the width or the height is set?

#3 @scribu
8 years ago

  • Component changed from Editor to Media

#4 @janeforshort
8 years ago

  • Milestone changed from 2.9 to 3.0

Moving to next dev cycle since we're already in beta.

#5 @azaozz
8 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [12660]) Clean CSS of the Edit Image popup in the visual editor props Simek, show changed image size and fill width or height when left blank, fixes #11655, fixes #10442

Note: See TracTickets for help on using tickets.