Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10456 closed defect (bug) (duplicate)

Media UI Improvements for the gallery tab

Reported by: hakre Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.8.1
Component: Media Keywords: needs-patch
Focuses: Cc:


If you create a new post that has not been saved, I encounter problems by uploading images.

After doing the upload (javascript and plugins allowed), there normally is a switch over to the details of the recently uploaded image. This does not work.

Next to this, the gallery tab does not appear. I assume both are releated to each other.

As additional feedback: It would be nice to have the gallery settings sections in galleries that consist of no or only a single image. The standard options could be offered or a text that tells the user to upload (more) pictures. This would make the UI more consistent and can help people to talk about using wordpress by phone better, because they see the same regardless of how many images they have uploaded.

(Version is infact 2.8.2 but that is not offered in the trac dialog)

Change History (11)

#1 @hakre
6 years ago

related: #9471

#2 @Denis-de-Bernardy
6 years ago

  • Milestone Unassigned deleted
  • Resolution set to duplicate
  • Status changed from new to closed

#3 @hakre
6 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Please reference the duplicate.

#4 @Denis-de-Bernardy
6 years ago

seems like the very same as #9471 to me...

#5 @dd32
6 years ago

The title(and half of the first sentence) is a duplicate of #9471

The rest about ajaxified gallery tab was mentioned in another ticket which i cant find, which was closed with the comment along the lines of Click the save changes button to activate it, Doing so also saves the image titles which you've probably added anyway

#6 @hakre
6 years ago

  • Keywords needs-patch added

For #9471, referenced it because it is related but it is not the same bug.

The second part - as already written - needs to go into it's own ticket then. If there really is a duplicate (not only memorized but link-able in tract), this can be handeled there then. Anyway the comment of dd32 IMHO AFAIK is not what I meant, so I even assume there is no actual duplicate at least not that one that dd32 is pointing to (Reference is #10489).

#7 @dd32
6 years ago

Theres a ticket, I cant find it. I was hoping someone else could find it instead, but its definately there and closed as invalid/wontfix

#8 @scribu
6 years ago

  • Milestone set to 2.9

#9 @azaozz
6 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Agree with dd32 and Denis-de-Bernardy. Most is a duplicate of #9471, the UI improvement part should be addressed when improving the media UI in general.

#10 @hakre
6 years ago

  • Milestone changed from 2.9 to 3.0
  • Summary changed from Image upload and media gallery does not work properly on unsaved new posts. to Media UI Improvements for the gallery tab

Regarding the UI improvements, I created new ticket: #11524

#11 @westi
6 years ago

  • Milestone 3.0 deleted
Note: See TracTickets for help on using tickets.