WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#10459 closed defect (bug) (worksforme)

HTML Editor jumps in IE8 with long permalink

Reported by: cddude229 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.8
Component: Editor Keywords: reporter-feedback
Focuses: Cc:

Description

While version says 2.8, I've seen it in 2.8.1 and 2.8.2 as well. Unaware of previous versions as I've never had to use IE8 with WP before 2.8.0.

I've only encountered this bug in IE8 with XP, but I've heard it is present in other versions of IE. (Heard being via posts on Wordpress.com while trying to debug this.)

Anyways, to reproduce:
1) Select "HTML Editor"
2) Create a long slug/post permalink so that it pushes the "View Post" button to the next line
3) Place your typing cursor near the end of the HTML editor box. (You should be able to type in the box.)
4) Attempt to move your mouse around the screen, hovering over other boxes such as "Publish" or "Excerpt." You should see the box jump back up.

I can give more information if necessary.

Change History (6)

comment:1 mrmist5 years ago

I'm not seeing this in rev 11731.

comment:2 scribu5 years ago

  • Milestone changed from Unassigned to 2.9

Probably related to #10438

comment:3 markjaquith4 years ago

  • Milestone changed from 2.9 to 3.0

scribu, did the closing of #10438 change this? Can you help crush this bug for 3.0?

comment:4 mrmist4 years ago

I reckon that this (and #10438 ) depends on the IE compatibility mode setting, as I can see the jumping when it's compatibility off but not on. In which case I'd be tempted to close this as invalid (although I suppose ideally it wouldn't jump in either case).

comment:5 ocean904 years ago

  • Keywords reporter-feedback added

Can't reproduce it in 3.0 either with or without compatibility mode.

comment:6 nacin4 years ago

  • Milestone 3.0 deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.