WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 22 months ago

Last modified 22 months ago

#10498 closed defect (bug) (fixed)

RSS widget filters some characters

Reported by: pavelevap Owned by: rmccue
Milestone: 3.4 Priority: normal
Severity: normal Version: 2.8.2
Component: Widgets Keywords: simplepie has-patch dev-feedback
Focuses: Cc:

Description

Hello, when inserting this RSS (http://servis.idnes.cz/rss.asp?c=mfd_k) into RSS widget then some characters are removed, for example č, í, ý, etc.

Attachments (1)

10498.diff (871 bytes) - added by solarissmoke 3 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 azaozz4 years ago

  • Milestone changed from 2.9 to 3.0

No patch, moving to 3.0

comment:2 dd324 years ago

  • Keywords simplepie needs-patch added
  • Milestone changed from 3.0 to Future Release

The root cause of this is SimplePie, It seems to be striping the characters instead of converting them to html entities.

Moving to future release due to no patch.

comment:3 solarissmoke3 years ago

  • Keywords has-patch dev-feedback added; needs-patch removed

The problem is that SimplePie tries to use mb_convert_encoding() without checking whether the encoding is supported. In this case, Windows-1250 isn't supported, so you lose all the special characters. You can check what is supported by calling mb_list_encodings().

Version 0, edited 3 years ago by solarissmoke (next)

solarissmoke3 years ago

comment:4 rmccue3 years ago

  • Owner changed from azaozz to rmccue
  • Status changed from new to assigned

I'm the SimplePie maintainer, so I'll look into this and report back.

comment:5 rmccue3 years ago

Pushed up to https://github.com/simplepie/simplepie/commit/cce56bb6809de9301909204c40c8a4f13ec322fe

Should be find to merge into WordPress' hacked up version. ;)

comment:6 pavelevap22 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

SimplePie 1.2.1 in WordPress 3.4 works well for this issue!

Tested on some websites - WordPress 3.3.2 shows this problem, but 3.4 is fine.

Fixed, thank you!

comment:7 nacin22 months ago

  • Milestone changed from Future Release to 3.4
Note: See TracTickets for help on using tickets.