WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 3 months ago

#10597 closed enhancement (duplicate)

More classes in menu generated using wp_list_pages and wp_page_menu

Reported by: newkind Owned by: ryan
Milestone: Priority: normal
Severity: normal Version:
Component: Menus Keywords: needs-patch
Focuses: Cc:

Description

I think that dev team should think about adding more classes to positions generated by wp_list_pages and wp_page_menu as it's very hard to style those menus. I'm thinking about class "parent" for every li that contains another ul etc. We got current_page_ancestor and others but they only work if you're on the child ...

Change History (4)

comment:1 scribu4 years ago

  • Milestone changed from Unassigned to 3.0

Related: #11817

comment:2 voyagerfan57614 years ago

  • Cc WordPress@… added

comment:3 Denis-de-Bernardy4 years ago

  • Keywords needs-patch added
  • Milestone changed from 3.0 to Future Release

comment:4 johnbillion3 months ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23834.

Note: See TracTickets for help on using tickets.