Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10598 closed defect (bug) (invalid)

Gallery Setting for 'Link thumbnails to...' Not Respected

Reported by: achmafooma Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Gallery Keywords:
Focuses: Cc:



Using WordPress 2.8.3 (just updated to 2.8.4) setting galleries to 'Link thumbnails to Image File' doesn't seem to work. Even with this setting set, gallery thumbnails open the attachment page when clicked.

This occurs both with old galleries (that used to work) as well as brand new ones. The setting seems to be properly retained, but it doesn't seem to DO anything.

Steps to reproduce:

1) Upload some graphics to a post.
2) Insert a gallery set to open thumbnails 'Image File'.
3) Post the entry and go to it
4) Click a thumbnail; it opens as an attachment page!

What should happen:

When the setting is 'Image File', it should open the image file instead of the attachment page!!

Change History (5)

#1 @achmafooma
6 years ago

  • Cc achmafooma added

#2 @azaozz
6 years ago

  • Keywords reporter-feedback added

Seems to work as expected in both trunk and 2.8. Have you changed themes recently? Perhaps your theme replaces the default gallery shortcode parser.

#3 @achmafooma
6 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Ah... I was using a plugin called 'Gallery Shortcode to Head' since the shortcode being in the body breaks XHTML validation. Apparently the plugin was causing this issue.

I'll report the issue to the plugin maintainer.


#4 @achmafooma
6 years ago

  • Keywords reporter-feedback removed

#5 @Denis-de-Bernardy
6 years ago

  • Milestone Unassigned deleted
Note: See TracTickets for help on using tickets.