WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#10608 closed defect (bug) (fixed)

The "fs_no_folder" error when upgrading the core dont shows its message

Reported by: jeff_ Owned by: dd32
Milestone: 2.9 Priority: low
Severity: trivial Version: 2.8.3
Component: Upgrade/Install Keywords: has-patch commit
Focuses: Cc:

Description

whe you are upgrading using autpaupgrade functionnality, if the "fs_no_folder" error is raised, you get no more explanations than "Installation failed".

It is caused by the message string reference that call a local var but not the class one in /wp-admin/includesclass-wp-upgrader.php.

Here is a patch.

Attachments (1)

class-wp-upgrader.php.diff (494 bytes) - added by jeff_ 5 years ago.

Download all attachments as: .zip

Change History (4)

jeff_5 years ago

comment:1 jeff_5 years ago

I forgot to mention it : the bug is there too in 2.8.4

comment:2 dd325 years ago

  • Component changed from Administration to Upgrade/Install
  • Keywords has-patch commit added; upgrade-core class-wp-upgrader.php removed
  • Milestone changed from Future Release to 2.9
  • Owner set to dd32

comment:3 ryan5 years ago

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.