WordPress.org

Make WordPress Core

Opened 11 years ago

Last modified 2 months ago

#10631 reopened defect (bug)

wp-admin/users.php does not show pages under "posts" column

Reported by: novasource Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.8.4
Component: Users Keywords: 2nd-opinion
Focuses: Cc:

Description

For some reason, the SQL query in wp-includes/user.php that gets the count of a user's posts excludes pages, so /wp-admin/users.php will not show an accurate picture of a user's contributions. This makes no sense at all: 1. posts and pages are first-class content types in WordPress and 2. they are both stored in the same table.

Proposed solution: remove

AND post_type = 'post'

from function get_usernumposts in wp-includes/user.php.

This defect could result in incorrect interpretation of user activity, so marked as major severity.

Change History (10)

#1 @dd32
11 years ago

  • Keywords 2nd-opinion added; users.php posts pages removed
  • Milestone changed from 2.8.5 to 2.9
  • Severity changed from major to minor

Why should a Posts column include the page count too? - Afterall, Its a Posts column.

Should it include Attachments too? What about custom post types?

The other option, is to change it to list the contributions, Ie:
"Activity: 5 Posts, 1 Page, 50 Comments" inline with your other ticket: #10629

#2 @novasource
11 years ago

  • Component changed from General to Users
  • Severity changed from minor to normal

Why should a Posts column include the page count too? - Afterall, Its a Posts column.

Because a page and a post are both posts. They are both first-class content types in WordPress that are remarkably identical.

When I delete spam users, a heuristic is those with a strange email address, 0 posts, and 0 comments (they are spammed or deleted). But suppose a user has 3 pages but 0 posts? Right now his post count would be 0. Is that a spam user?

Should it include Attachments too?

Not sure that provides much value. Attachments are a piece of a page/post.

What about custom post types?

Not familiar enough with the custom post type ecosystem to comment.

The other option, is to change it to list the contributions, Ie: "Activity: 5 Posts, 1 Page, 50 Comments" inline with your other ticket: #10629

That consolidates all three counts in one field and makes it more difficult to scan large lists. In that other ticket, I also proposed a way to make a sparse matrix more usable--use a blank instead of a 0. This would defeat that significant usability improvement.

#3 @ryan
11 years ago

  • Milestone changed from 2.9 to Future Release

#4 @westi
11 years ago

  • Milestone Future Release deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing as invalid.

The posts column on the users list is just that the number of posts a user has written and this works as designed.

#5 @fouldsy99
5 years ago

how can you make posts column sortable?

#6 follow-ups: @fouldsy99
5 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

how can you make posts column sortable?

#7 in reply to: ↑ 6 @chriscct7
5 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Replying to fouldsy99:

how can you make posts column sortable?

This is not a support forum, it's a development tracker. If you need help, please see https://wordpress.org/support/

#8 in reply to: ↑ 6 @SergeyBiryukov
5 years ago

Replying to fouldsy99:

how can you make posts column sortable?

See #15861.

#9 @AnthonyHall
2 months ago

Please reopen this ticket
Saying it is working as designed is not helpful. The question is what is needed? Why is it useful to show posts but not pages?
For example, when I'm about to delete a user it asks me who I want to allocate their content to. If this content includes pages,I need to know which ones. This seems very difficult to find out at the moment.
Saying "The posts column on the users list is just that the number of posts a user has written " is also unhelpful: as the novasource said, pages are posts. The fact that posts can mean posts or "posts except pages" is a fault in WordPress, not a fault in the ticket.

#10 @AnthonyHall
2 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Please reconsider this ticket

Note: See TracTickets for help on using tickets.