WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#10639 closed defect (bug) (invalid)

Media and Image Upload PHP Errors - "Too many levels of symbolic links"

Reported by: mrquint15 Owned by:
Milestone: Priority: high
Severity: normal Version: 2.8.4
Component: Upload Keywords:
Focuses: Cc:

Description

In the media library, in 2.8.4 (this bug existed for me in 2.8.3 as well), image uploads return the following error:

Warning: is_dir() [function.is-dir]: Stat failed for /nfs/c01/h03/mnt/32054/domains/xxx.xxx.xxx/html/wp-content/uploads/2009 (errno=40 - Too many levels of symbolic links) in /nfs/c01/h09/mnt/32054/domains/xxx.xxx.xxx/html/wp-includes/functions.php on line 1942

I am unable to upload new images, or manipulate images that are currently in the system. This error message is repeated all the way down the page in the media section of the admin screen, and appears three times after attempting to add a new image.

This site is hosted on a Media Temple Grid Server. There is a recent forum posting I found that confirms the issue is not isolated to just me: http://wordpress.org/support/topic/301606?replies=5

Attachments (1)

media-library-screenshot.png (69.0 KB) - added by mrquint15 5 years ago.
Screenshot of the errors that appear on the Media Library section of the admin

Download all attachments as: .zip

Change History (4)

mrquint155 years ago

Screenshot of the errors that appear on the Media Library section of the admin

comment:1 scribu5 years ago

  • Component changed from Media to Filesystem
  • Keywords errno=40 media images uploads symbolic link removed
  • Milestone changed from Unassigned to 2.9
  • Owner set to dd32

comment:2 dd325 years ago

  • Component changed from Filesystem to Upload
  • Owner dd32 deleted

This is a unique issue to certain web hosters..

I'm not sure WordPress can even attempt to work around it, Due to an inibuilt PHP filesystem function (is_dir()) is failing.. Its like not its a special function that WordPress is using or anything, Its stock standard PHP..

I'd be taking it up with your web host honestly.

comment:3 ryan4 years ago

  • Milestone 2.9 deleted
  • Resolution set to invalid
  • Status changed from new to closed

I don't think there's anything we can do here.

Note: See TracTickets for help on using tickets.