WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 3 years ago

Last modified 3 years ago

#10666 closed feature request (fixed)

When an upgrade borks, There needs to be an ability to rollback

Reported by: jorbin Owned by:
Milestone: 3.7 Priority: normal
Severity: normal Version:
Component: Upgrade/Install Keywords: close
Focuses: Cc:

Description

When an upgrade borks, there should be a simple script that allow you to rollback to the previous version. It should be mostly separate from the admin interface and allow for the restoration of both a database and the files associated with the previous version.

Change History (8)

#1 @scribu
8 years ago

  • Milestone changed from Unassigned to Future Release
  • Type changed from enhancement to feature request

#2 @Denis-de-Bernardy
7 years ago

I'd say close this one as fixed in WP 2.9, or wontfix. We check for PHP/MySQL version, and we abort as needed. Once we touch the database, there really isn't much turning back.

#3 @scribu
7 years ago

We could make a backup of the database before attempting an upgrade. Don't know how well that would work on MU though.

#4 @hakre
7 years ago

  • Milestone changed from Future Release to 3.0

This is a Feature Request for 3.0 (at least wished: #11646).

#5 @nacin
7 years ago

  • Milestone changed from 3.0 to Future Release

No traction on this.

#6 @jeremyfelt
3 years ago

  • Keywords close added

Our handling of a failed upgrade is much better now at the file level now. When automatic upgrades were introduced in 3.7, a lot of work went toward making sure this process is clean. I'm not sure what kind of DB stuff we could do on top of that.

Should this ticket remain open for attention, or are we pretty well set for now?

#7 @jorbin
3 years ago

  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Jeremy is correct. I think we are pretty well set now with all the work done in 3.7 and this is no longer needed. Maybe some point in the future this will make sense, but I don't think we are going to go in that direction.

#8 @nacin
3 years ago

  • Milestone set to 3.7
  • Resolution changed from wontfix to fixed

Actually, this was implemented as part of background updates in 3.7. It's extremely limited by design but reverses the vast majority of critical failures. If a background update experiences a critical failure when using a partial build, it'll attempt to copy old files back over. If that works, then it'll call the whole thing a standard failure (as if it was never able to update at all).

Note: See TracTickets for help on using tickets.