WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#10681 closed defect (bug) (invalid)

Gallery Navigation: Next or Last Image not displayed

Reported by: blabbr Owned by:
Milestone: 2.9 Priority: normal
Severity: normal Version: 2.8.4
Component: Gallery Keywords: reporter-feedback
Focuses: Cc:

Description

I've inserted a gallery in several of my posts.
When one views the images of the gallery (click on thumbnail) and skips through the images using the gallery navigation very often there is a problem with viewing the last image: at the second last image there isn't a link to the last one. If one opens the last image directly there isn't a link to the second one.
If one opens the first image and the link to the last image doesn't work, in the first image there's a link back to the last image. It seems the navigation is shifted by 1 image in these cases.
What's really curious is that it isn't really reproducable: In some posts it works, in others it won't.
In one gallery i also discovered an interruption right in the gallery getting from one picture to the next eventhough it's not the last one.
Tried it with several browsers and layouts. No modifications expect some design tweaks have been made. Doesn't work with default theme either.
Link to gallery where link to last image doesn't work:
http://www.kition.net/1547, http://www.kition.net/1620
Link to gallery where link to last image works:
http://www.kition.net/1656, http://www.kition.net/1676
Special case where there's an interruption in between:
http://www.kition.net/1676/20090817_13

Let me know if you need any more information. Thanks for this great blog!

Change History (5)

comment:1 scribu5 years ago

  • Component changed from General to Gallery

[Added paragraphs for legilibility]

I've inserted a gallery in several of my posts. When one views the images of the gallery (click on thumbnail) and skips through the images using the gallery navigation very often there is a problem with viewing the last image: at the second last image there isn't a link to the last one.

If one opens the last image directly there isn't a link to the second one. If one opens the first image and the link to the last image doesn't work, in the first image there's a link back to the last image. It seems the navigation is shifted by 1 image in these cases. What's really curious is that it isn't really reproducable:

In some posts it works, in others it won't. In one gallery i also discovered an interruption right in the gallery getting from one picture to the next eventhough it's not the last one. Tried it with several browsers and layouts. No modifications expect some design tweaks have been made. Doesn't work with default theme either.

Link to gallery where link to last image doesn't work:

http://www.kition.net/1547, http://www.kition.net/1620

Link to gallery where link to last image works:

http://www.kition.net/1656, http://www.kition.net/1676

Special case where there's an interruption in between:

http://www.kition.net/1676/20090817_13

comment:2 scribu5 years ago

  • Keywords reporter-feedback added; gallery navigation nav image removed

Maybe it is caused by a plugin. Have you tried on a fresh install?

comment:3 scribu5 years ago

  • Milestone changed from Unassigned to 2.9

comment:4 miqrogroove4 years ago

To help clarify the OP, there is nothing wrong with the navigation links. There appears to be a sorting issue that is causing one of the images to be displayed last on the post page but first among the image pages. I will follow up if I can see any way to reproduce that behavior.

comment:5 miqrogroove4 years ago

  • Resolution set to invalid
  • Status changed from new to closed

This is very easy to reproduce. When adding galleries to posts, the author is given the option to insert code like [gallery orderby="title"] rather than [gallery]. This creates an explicit sorting mismatch between the post and the image pages.

OP may reference this ticket in the support forums, but I am marking the bug invalid.

Note: See TracTickets for help on using tickets.